Free Support Forum - aspose.com

17.2 version of the convert error problem

Hi Aspose team,

I am using Aspose Slides 17.2 and 16.2 to convert a PPT file to a svg file.
But get different results. The 16.2 version seems to be more correct.
I have uploaded origin PPT file and comparison of the two versions.
Please check the attachment, and help me solve this issue, thanks!

Hi Lai,

I have observed the information shared by you and tried exporting the shared presentation slides to SVG using following sample code. I have not been able to observe the issue in exported output when using Aspose.Slides for Java 17.4 in Windows 7 x64 with JDK1.7.0 on my end. For your kind reference the generated output is also attached. Can you please try using specified version on your end.

public static void ExportSVG()

{

String MyDir=“C:\Aspose Data\result\”;

Presentation pptDocument = new Presentation(MyDir + “issue.pptx”);

int pageCount = pptDocument.getSlides().size();

ISlide pageSlide = null;

for (int i = 0; i < pageCount; i++) {

try {

pptDocument.getSlides().get_Item(i).writeAsSvg(new FileOutputStream(MyDir+“SvgImage” + i + “.svg”));

}

catch(Exception e)

{

System.out.println(“Issue on generating Slide :”+(i+1)+" Svg");

}

}

}

Many Thanks,

Hi
I use Aspose.Slides for Java 17.5-jdk16 in Windows is normal.
But in the Linux environment will be wrong.

I have uploaded origin PPT file and mark the wrong part of the pictures.
Please check the attachment, and help me solve this issue, thanks!linux.zip (993.5 KB)

@janetchu,

I have worked with source code and presentation file shared by you using Aspose.Slides for Java 17.7 and have been able to observe the issue. A ticket with ID SLIDESJAVA-36569 has been created in our issue tracking system to further investigate and resolve the issue. This thread has been linked with issue so that you may be automatically notified once issue will be fixed.

We are sorry for your inconvenience,

The issues you have found earlier (filed as ) have been fixed in this update. This message was posted using BugNotificationTool from Downloads module by MuzammilKhan