Free Support Forum - aspose.com

3D chart style settings doesn't work in method toImage

Hi!

I am trying to create image from chart by method toImage. The problem is, it seems, that this method doesn’t support chart style setting (or 3D settings). Does any body now workaround for this? (I have tried this method with the last verstion of Aspose.Cells - 7.4.3)

I have attached screenshots and source code.

Hi,


I can notice this limitation as you pointed out for Chart to Image feature, the 3D style/formatting is not rendered in the output image, we will check if we could support this feature.

I have logged a ticket with an id “CELLSJAVA-40499” for your issue. We will look into it soon.
Once we have any update on it, we will let you know here.

Thank you.

OK, thank you for answer.

Hi,

Thanks for your posting and using Aspose.Cells.

We are afraid the 3d-Format is not supported. Please set other style for chart. Also, Please specify the file format type when you want to create2007 formatted file.
e.g.
new WorkBook(FileFormatType.XLSX).


Hi Shakeel!

It seems, that all another chart styles doesn’t supported too. I have tried to set values from 1 to 48 (by method ‘setStyle’ of Chart), and result is the same. It’s differ from default style, but all of 48 styles looks the same.

Hi,

Thanks for your posting and using Aspose.Cells for Java.

We have logged your comments in our database. We will look into your issue and help you asap. Once, we will have some update for you, we will let you know asap.

Hi,

Thanks for your posting and using Aspose.Cells.

Please try the attached code segment. For setting style, you must specify the file format when create workbook object. There are 2 issues in the current version.

1, The styles of 17-32 and 41-48 are not supported. The feature is too complex. We cannot provide a fix in near future. Please set other styles now.

2, Chart2Image feature don’t support setting resolution. We will try to look into it and provide a fix recently.