We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

79 page report takes over 5 minutes to render ppt slides

We have some reports that are 79 pages long that we would like to generate PT slides from. The 79 Slide PPT file takes over 5 minutes to render.

Are there any tricks to speed this up?


This message was posted using Aspose.Live 2 Forum

Hello Dear,

Thanks for your interest in Aspose.Slides.

I feel that the issue might be with the contents inside the report. There may be some processing of data that may have to be done before adding that to report and later on rendering to PPT. Aspose.Slides for RS renders the report as is to PowerPoint formats. Can you please share, how much time is required for exporting to TIFF and PDF for comparison. Unfortunately, there is no way to speed up the things and rendering of data varies on complexity and type of data. Like graphics contents will take more time to render. Hope it clears the query.

Thanks and Regards,

Hello,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thank you for your response. The contents of the reports are nothing out of the ordinary. Each slide has a chart on it. It seems that approx 6 seconds per slide is entirely too slow.

PDF and MS Word rendering for that report take 10 seconds.

Is there a log that gets generated, so we may be able to see where the rendering is slowing down?

Hello Dear,

Thanks for sharing the further piece of information. Based on the time scales shared by you, I may need to reproduce the issue on my and for that I request you to please share the RDL using AdventureWorks as data source for necessary investigation. I really appreciate your cooperation in advance for this.

Thanks and Regards,

Doing a similar timing on a much simpler report that consisted only of a RDL table also produced significant slow downs. In that case it was a 2 page report consisting of a table of about 40 items. It took less than 4 seconds to export to PDF (using the standard export) and over 30 to export to PPTX using Aspose. So, I constructed another similar report against the AdventureWorks database as a demo. It is attached. It also consists of just a table that lists the contents of the Products table. That table has 1000 rows, renders to 10 pages and exports in less than 10 seconds to PDF. Aspose’s export was impressively worse. It pinned the CPUs of the reporting server and slowly allocated at least two gigabytes with no signs of stopping. After some long amount of time, easily over 10 minutes, it still had not produced any output. We tried this two other times with the same results, and the performance behaviour was definitely associated with attempting to export those reports. This is completely unacceptable.

Hi Derek,

Thanks for sharing the desired information.

I have worked with RDL file shared by you and have observed the fact that report rendering takes significant amount of time when exporting to PDF as against to PDF. An issue with ID 27107 has been created as investigation in our issue tracking system to further investigate and resolve the issue. This thread has been linked with the issue so that you may be notified, once the issue is resolved.

We are sorry for your inconvenience,

Dear Customer,

I've tried to export report that you've provided and got the following resutl:

PPT with 185 pages was exported near near 40 seconds on Athlon mobile CPU.

Anyway we are working on component performance analysis at this moment.

Can you provide PPT you've generated with provided test rdl please?

Thanks

PS You can find PPT attached.

Hello,

I can confirm that this problem still persists in version 3.9.0 (full), SQL 2008 R2 CU8.

I have several seconds for PDF and 20-25 minutes for PPT, for ~200 pages.

I have another report with 500 pages and I usually kill the process because it goes longer than 30 minutes. It seems that the generation time grows exponentially with the data. Please find the attached RDL, I even removed footer and header so that it consists of a very simple table only - using AdventureWorks DB.

Hi Darek,


Thanks for sharing the information. I have moved request to concerned developer for further investigation.

Many Thanks,

The issues you have found earlier (filed as 27107) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.