Access Denied: Aspose PDF


#1

We have been using aspose.pdf to generate documents with the back ground data coming out of a DB. Things have been working great since we started using it in July.

Using Server 2k, IIS5, SQL Server 2000, DotNet Frame Work 1.1.4, and Aspose 2.6.0.0

Yesterday we had a network outage and the servers got rebooted. Now anytime anyone goes to the web page and tries to generate the pdf they get the Access Denied error.

I downloaded the most recent version of the DLL and installed that.

Checked to make sure that the DotNet user on the server has read/write/execute access to the web folder and the bin folder where the DLL resides.

Everything still works correctly on our developmental machine

Any other ideas?

Pete


#2

Dear Pete,

Thank you for considering Aspose.

I suggest that you write a simple ASP application that read and write file and check if it can work. You can also try to add the following line to the web.config and see if it can work:

If this works, that means there is problem about security setting.

If you still can't solve the problem please provide the error message and let me check it.


#3

Thanks for the response.

What I ended up doing was to delete every aspose.pdf.dll that existed on the web server. All of the older versions of the PDF that we had replaced were still residing down in the winnt/net framework fold.

When we update to a new version, we have just been placing the dll into the wwwroot/bin directory. But never looked in the framework folder.

I dont know if it was the 4 different dll's hiding that caused problems or not. But after deleting every single dll I could find on the server and then puting the 2.6.0.0 dll into the web sites bin folder everything is working again.

Great idea about creating a simple application to test PDF generation. I will pull one of the samples off of here and load that to use for future testing.

Thanks

Pete


#4

Looks like I spoke too soon.

PDF generation just stopped working again. Seems like everything works fine for about 24-30 hoursa then we get the access denied error.

Server Error in '/' Application

Access is denied: 'Aspose.pdf'

An unhandled exception occured during the execution of the current web request. Please review the stack trace for more information about the error.

Exception Details: System.IO.FileLoadException: Access is denied 'Aspose.pdf'

If I add my username and pasword into the config script as recomended I get an error

"Could not create windows user token from the credentials specified in the configuration file"

I am going to try the test script, but have a feeling I am going to have to delete the dll's, reboot the server, then put the dll's back in place. Same as yesterdaySad [:(]


#5

OK rebooted the server and now everything works fine again.

Anyone else ever seen an issue like this, where rebooting fixes the Aspose PDF generation?

Pete