Free Support Forum - aspose.com

Access is denied: 'Aspose.Words'

I'm using Aspose.Word for a Sharepoint 2003 project. In my developing enviroment everything works, but when moving to testerver problems has started.

My first try wnt alright, I created the document I wanted. Now when trying again, I get the following error, Find similar problem under thread : Aspose.Pdf Access denied , and link to: http://www.asp.net/learn/whitepapers/denied-access-to-iis-directories/

But it didn't help me. Please give me some advice.

Access is denied: 'Aspose.Words'.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.IO.FileLoadException: Access is denied: 'Aspose.Words'.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.


Assembly Load Trace: The following information can be helpful to determine why the assembly 'Aspose.Words' could not be loaded.

=== Pre-bind state information ===
LOG: DisplayName = Aspose.Words, Version=8.2.1.0, Culture=neutral, PublicKeyToken=716fcc553a201e56
 (Fully-specified)
LOG: Appbase = file:///C:/Program Files/Common Files/Microsoft Shared/Web Server Extensions/60/template/layouts
LOG: Initial PrivatePath = bin
Calling assembly : Instant.SixSigma.Common, Version=1.0.3758.16242, Culture=neutral, PublicKeyToken=null.
===

LOG: Attempting download of new URL file:///C:/WINDOWS/Microsoft.NET/Framework/v1.1.4322/Temporary ASP.NET Files/_layouts/7908a291/1034c155/Aspose.Words.DLL.
LOG: Attempting download of new URL file:///C:/WINDOWS/Microsoft.NET/Framework/v1.1.4322/Temporary ASP.NET Files/_layouts/7908a291/1034c155/Aspose.Words/Aspose.Words.DLL.
LOG: Attempting download of new URL file:///C:/Program Files/Common Files/Microsoft Shared/Web Server Extensions/60/template/layouts/bin/Aspose.Words.DLL.

Hi

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thanks for your request. Have you tried clearing ASP.NET temporary folder? Maybe this will help to resolve the problem. Also, maybe information provided here could help you:

http://social.msdn.microsoft.com/Forums/en-US/clr/thread/0539b6bd-3177-4e89-ac01-07a2f7d71df4

Hope this helps.

Best regards.

As I understand it I have to stop and restart the IIS while clearing the temporary folder? I did iisreset and the application works. my question now is; Do I really have to make an iisreset? my Customer is not so keen on restarting iis every time we made a change in the dll that calls Aspose.words.dll.

Hi

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thanks for your request. I do not think that you need to reset IIS every time you made some changes. I suppose, such error occurs because some failure in IIS.

Have you tried the suggested way to resolve this problem? Does it help you?

Best regards.

As far as I can tell ASP.Net already has access to those folders.
If I clear the temp Asp.Net files don’t I have to stop iis while it´s done?

Hi

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thanks for your request. Since IIS uses files from this folder, you should stop IIS in order to remove all files from the temporary ASP.NET folder.

Best regards.

So it is now way to come around the problem without stop IIS…

So it is no way to come around the problem without stop IIS…

Hi

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thanks for your inquiry. Actually, this is not problem of Aspose.Words, such problem occurs because something wrong in IIS. So I cannot see any other way to resolve the problem without restarting IIS.

Best regards.