Free Support Forum - aspose.com

AddField with FieldType.MultiLineText

The AddField method works fine when NOT specifying an initial value for the field. However, if an initial value is specified an exception is thrown: ‘Unknown field type’. What am I missing?

Further testing also appears to indicate another quirk with AddField ... the FormFieldFacade is only applied if the AddField specifies an inital string value for the field.

Hi,

I have tested this and was able to reproduce the error. I have logged this as PDFKITNET-4360 in our issue tracking system. We will try our best to resolve this as soon as possible.

Thanks.

Which error was reported? The 'inital value' or the Facade problem?

Thanks,

Dan Schless

Hi,

The initial value problem is logged as issue. The AddField method works fine when NOT specifying an initial value for the field. However, if an initial value is specified an exception is thrown: 'Unknown field type'.

Thanks.

So, is the the issue with the FontFacade, mentioned above, considered a bug?

Thanks for all your help,

Dan Schless

Hi,

I have note been able to reproduce the error that you reported with FormFieldFacade. Please provide us with code that can reproduce this error so that we can more accurately determine the cause of the problem.

Thanks.

Dear dschless,

Thanks for your patience. Both bugs have been fixed and submitted for more testing. They will be included in the newest release, which will come soon.

Best regards.

Hi,

Please download new version 3.0.