Free Support Forum - aspose.com

Adobe Acrobat Reader 6 and 7 version documents decryption

Hello, I have one question. When I try to decrypt these PDF document versions I get following error. Unknown encryption type: 4 Does anybody know where is the problem? Does Aspose.PDF.Kit support these versions or will support them in the future? Thank you

Dear subwoofer,

Thanks for considering Aspose.Pdf.Kit.

I suppose the type of encryption is not supported in current version, can you attach the pdf file,? I will test on my machine.

Best regards.

Thank You for prompt reply, there is a pdf file that I used for decryption. The password is heslocsni

Dear,

I tested on my machine, the attached pdf file conforms to the Pdf Reference v1.6, "Unknown encryption type: 4" indicates that the file uses a new encryption algorithm which is not supported in current kit. I have suggested appending the support for the new encryption in our developing plan, but it won't be gotten in a short time.

Best regards.