We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

After adding chart (oleobject+image) cannot open with Open Xml SDK 2.5

My company is evaluating Aspose product and we came across the following problem

We create new workbook, add 3 worksheets, in each worksheet we add one oleobject(image+ oleobject data).
When we try to open the generated workbook in Open XML SDK 2.5 i get the following error

Cannot open the file: Part /xl/drawings/vmlDrawing1.vml ‘data’ is a duplicate attribute name. Line 1, position 204

Hi Daniel,


Thank you for considering Aspose APIs.

I am afraid, we need more information to replicate the problem, and move forward towards the correction (in case the issue is established as a bug on the part of Aspose.Cells APIs). We would request you to please provide us a standalone sample application along with all required resources (images, template spreadsheet) to re-create a workbook that could allow us to observe the problem as demonstrated in your provided snapshot. Upon receiving the above requested, we will thoroughly investigate the said scenario to assist you further in this regard.

Before you provide us the requested information, we would request you to give this scenario another try against the latest version of Aspose.Cells for .NET 8.3.0.

Looking forward to your kind response.

Attached you can find a visual studio sample project. I installed the latest aspose this week so i am using the latest version of the software.

Hi Daniel,


Thank you for providing the sample application.

We have evaluated the complete scenario while using the latest version of Aspose.Cells for .NET 8.3.0 & Open XML SDK 2.5 for Microsoft Office, and we are able to replicate the exact error on our end. The said problem has been logged into our bug tracking system under the ticket CELLSNET-43176 for further investigation. Please spare us little time to isolate the problem cause, and to provide the solution for it. In the meanwhile, we will keep you posted with updates in this regard.

Hi Daniel,


This is to bring in your knowledge that the ticket logged earlier as CELLSNET-43176 has been marked resolved, and we hope to provide the fix in couple of days after performing the QA over it. As soon as the release containing the aforesaid fix is ready for public use, we will notify you here along with the download link to the upgraded API.

Thank you for your patience with us.

Hi,

Thanks for your using Aspose.Cells.

Please download and try the latest fix: Aspose.Cells for .NET v8.3.0.2 and let us know your feedback.

I confirm that the issue is fixed with the provided version 8.3.0.2.

Thank you for the quick response

Hi,


Thanks for your feedback.

Good to know that your issue is resolved by the new fix/version. Feel free to contact us any time if you need further help or have some other issue or queries, we will be happy to assist you soon

Thank you.

The issues you have found earlier (filed as CELLSNET-43176) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.