We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

After save word document as pdf format- space becomes box

I am using Aspose.Word.dll version 9.7.0.0.

I have a word document(C:\temp\Spaces.doc) with includes some spaces. The font is Arial

Standard Space: A B

Em Space: A B

En Space: A B

¼ Em Space: A B

Nonbreaking Space: A B

After I save this word document as pdf format(C:\temp\Spaces.pdf), the pdf file will show boxes in those spaces.

Evaluation Only. Created with Aspose.Words. Copyright 2003-2010 Aspose Pty Ltd.

Standard Space: A B

Em Space: A□B

En Space: A□B

¼ Em Space: A□B

Nonbreaking Space: A B

My Code is:

Aspose.Words.Document doc = new Aspose.Words.Document();

doc = new Aspose.Words.Document(“C:\temp\Spaces.doc”);

string inFile = “C:\temp\Spaces.pdf”;

doc.Save(inFile, Aspose.Words.SaveFormat.Pdf);

Anybody can help me? Thanks

Hi Michelle,

Thanks for your inquiry.

Could you please attach your document here for testing?

Thanks,

Thanks Adam. I attached the file to my original post

Hi Michelle,

Thank you for additional information. Unfortunately, I cannot reproduce the problem on my side. I attached PDF document produced on my side. As you can see it looks the same as your input Word document.

Could you also attach your output PDF here? I will try to find a difference between your PDF and my.

Best regards,

Hi Alexey,

I attached the PDF file I generated on my side to my original post.

Thanks,

Hello,

Thank you for additional information.
Unfortunately I also could not reproduce your problem on my side. Could you please specify what software you use. And also, could you try to convert the document on another computer, that would exclude the possible problem on your local machine.

Hi Viktor,

I have already tried in three different machines. My machine is Window XP.

I built a simplest project just testing saving word document as pdf format. I attached it to my original post.

The Aspose.Words.dll I used is 9.7.0.0 version, with 5.32 MB (5,586,944 bytes) size on disk.

Thanks,

Thank you for additional information.
Most likely you just have an old version of the Arial font. And in this font are no glyphs for these spaces as you have in your document.
I put my own font version 5.06. Please try installing it on your computer and then convert the document again.

It is because of the version of the Arial font.

Thanks for the help!

Michelle

Does this issue affect a few fonts like Arial, or does it affect other fonts as well?

Where can I get the new version for all the other fonts?

Are there any sources on the web that I can download?

Thanks in advance.

Hello,

In your case in the document were very original spaces. Probably copied from html pages.
New fonts you can take from computer where Windows 7 installed . Unfortunately I could not find a resource site where microsoft would have to download new versions of fonts. But I think you can easily find it out from microsoft tech support .

Hi, Viktor

I called Microsoft, and they provided me a link: http://www.microsoft.com/typography/fonts/family.aspx?FID=8

One thing I am puzzled is that: their Arial font version history (bottom part of this page) only has up to version 2.55, but the font you gave to me is version 5.06. Is it because your version 5.06 is newer or has different meaning as the one in this site?

Hi Michelle,

Thank you for additional information. 5.06 version of font is the version included in Windows 7. I am not sure why this version is not listed in the history.

Also, have you tried installing windows updates? Usually new versions of fonts are installed with windows updates.

Best regards,

Hi,

We are having this issue again: after saving word document as pdf format, space becomes box.

Now we are using Aspose.Words version 10.7.0.0.

My machine is windows XP.

Our product is a web application.

I had 9 Arial fonts on my machine before:

· arial.ttf

· arialbd.ttf

· arialbi.ttf

· arialli.ttf

· ariblk.ttf

· ARIALN.TTF

· ARIALNB.TTF

· ARIALNBI.TTF

· ARIALNI.TTF

I first updated 7 Arial fonts except the first two (arial.ttf & arialbd.ttf) with the Arial fonts in Windows 7 machine. It works: boxes are gone. It seems updating these 7 fonts made this happen.

But the bizarre thing is that after I deleted all of these 7 updated Arial fonts, it still works. Now my machine only has the first two arial fonts which are my original fonts.

Could any Aspose expert explain to me why?

Hi Michelle,

Thanks for your request. Could you please attach your document here for testing? We will experiment on our side and provide you more information.

Best regards,