We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Allow row to break across pages in PDF

We are not able to use the “Allow row ro break across pages” option when we save the Aspose Document as PDF.

I have attached the same document once saved as Docx (Correct) and once as PDF (not correct).

Please let us know how we can solve that issue.

Hi Christian,


Thanks for your inquiry. Please use the latest version of Aspose.Words for .NET and try following code example. Hope this helps.


Document doc = new Document(dataDir + "AM_Doc_f66620b6-6525-4dec-98fc-b7c4024523bc.docx");

foreach (Cell cell in doc.GetChildNodes(NodeType.Cell, true))

{

cell.EnsureMinimum();

foreach (Paragraph para in cell.Paragraphs)

if (!(cell.ParentRow.IsLastRow && para.IsEndOfCell))

para.ParagraphFormat.KeepWithNext = true;

}

doc.Save(dataDir + "PDF.pdf");


For more information kindly visit Working with Columns and Rows. If you still face any problem, please let us know we will try to help you as much we can. Thanks.

Thank you very much for this quick answer.

The word file is correct and this setting is already set within word, so why do we need to do it programmatically?

I think this is just a convertion issue, when we save this AsposeDoc as docx everything looks fine, but when we save the same AsposeDoc as PDF this setting will be ignored.

Could you please advice how we can proceed in this case.

Thank you

Hi Christian,


You’re right. For the sake of correction, we have logged this problem in our issue tracking system as WORDSNET-14718. Our product team will further look into the details of this problem and we will keep you updated on the status of correction. We apologize for your inconvenience.

Best regards,

The issues you have found earlier (filed as WORDSNET-14718) have been fixed in this Aspose.Words for .NET 17.3.0 update and this Aspose.Words for Java 17.3.0 update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.