We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

"Cannot find any fonts installed on the system" when upgrading to Aspose Slides 15.5.1

We update to version 15.5.1 from 15.3.0.
On our production Ubuntu Linux system we get

"Cannot find any fonts installed on the system" when upgrading to Aspose Slides 15.5.1

When saving a diagram.
On another Ubuntu Linux system we have no problem with the same upgrade.
Find attached the relevant part of the log.

With kind regards,
Ad van Ommen
PwC

Hi Ad van Ommen,

I have observed the comments and log shared by you. As you have shared that the same presentation files works for you in another machine instance as well but failing on one of Ubuntu installation. It seems to be some issue with fonts on your machine. I suggest you to copy the Fonts from Ubuntu machine where things are working on your end to machine where things are failing. You can install the missing fonts or can even call them externally using FontsLoader. Please share, if I may help you further in this regard.

Many Thanks,

Thanks for your reply and suggested fix.

We did investigate and add some fonts packages to the Ubuntu Linux machine, even before you suggested it. This did solve our immediate problem.

We still wonder how upgrading to a newer version of Aspose Slides made a difference. I could not find anything specific about this dependency on fonts in the release notes, nor in the general documentation.
We are very much interested in all of the dependencies, and especially how they change with updated versions of Aspose Slides. Is there a comprehensive documentation available?

Kind Regards,
Ad van Ommen
PwC


Hi Ad van Ommen,

I like to share that we share the information about any changes in API with every product release. Please visit this documentation section for your kind reference in this regard. Please share, if I may help you further in this regard.

Many Thanks,