Free Support Forum - aspose.com

"Some controls on this presentation can't be activiated"

I"m getting the following error message when opening a PPT file into which I copied a slide that contained an embedded Flash object:

Some controls on this presentation can't be activated. They might not be registered on this computer.

However, if I open the source PPT that contains the slide with the Flash object it's fine. No error. It's only after the slide is copied to the target PPT and this is opened that I get the error. Any ideas? I'm using the CloneSlide method to copy the slide.

I have attached both the source and target PPTs.

Regards,
Dave

We are having the same issue. Is there a solution for this?

We’re having the same issue, although we have embedded Windows Media instead of Flash object.

Here are the samples.



Hi,

We are investigating the issue and let you know as soon as it is resolved.

Hello,

Unfortunately ActiveX controls embedded to a slide can’t be cloned properly. Sorry but it won’t work after cloning.

The possible workaround is use presentation with ActiveX control as source template and clone other slides to this one.

Could you post some more details about using a template? I can created a new Presentation object from an existing file (and the video seems to work fine), but when I try to add additional slides that also have embedded media objects, I get the same error as above.

Is there a way to append multiple PPT files into one with Aspose? (I.e. not using cloning)

Hi,

Currently, this is the only workaround as suggested by Alexey. Another way to play any movie on a slide is using the Shapes.AddVideoFrame method.