We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Any plans to switch from Java 6 to 7 or later for runtime?

We’re very pleased to see that Aspose.Words for Java requires a minimum of Java 6 at runtime, hence the name of the library aspose-words-18.12-jdk16.jar. No doubt there will be (legacy) applications that have integrated Aspose.Words for Java, though that cannot easily migrate to a later JRE / JDK.

My question is more on the long term: does Aspose have any plans to increase the minimum Java version as per the System Requirements from Java 6 to 7?

@PieterB

Thanks for your inquiry. Currently, we do not have any plan to move Aspose.Words for Java code baseline to Java 7.

1 Like

The Aspose.Words for Java 19.3 release notes include the following change:

Release JAR is upgraded to JDK 7

Upon my previous request, there were no such plans back in December so can you clarify this particular change?

  • What JDK release is used to compile the Aspose.Words for Java code?
  • What is the minimum Java release required at runtime? Has this change from Java 6 to 7 with this change?

@PieterB

Thanks for your inquiry. December 2018 is end of extended support for Java 6. So, we upgraded release JAR to JDK 7 in the latest version of Aspose.Words for Java 19.3.