Free Support Forum - aspose.com

Apsose PDF - OSGI Issue

Hello,


We are using the aspose-pdf-10.3.0.jar in Jboss Fuse OSGI container. The way the META-INF has been defined is causing issues in loading of the jar.

Please repackage the Jar with out the following line in the META.INF file.

Export-Package: com.aspose.pdf

The use of this jar is completely limited as we need to use other packages. Or you can export all the packages to avoid this problem.

This for use by Connecture Inc and we are stuck at this moment.

Thanks,
Chamal


Hi Chamal,


Thanks for your inquiry. We have already logged a feature request ticket PDFNEWJAVA-34093 in our issue tracking system for providing Jar for OSGI container. We have passed your concern to product team as well and requested to implement it as soon as possible. We will notify you as soon issue is resolved.

We are sorry for the inconvenience caused.

Best Regards,

The issues you have found earlier (filed as PDFNEWJAVA-34093) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.
(2)
I am not seeing exports for the following packages:

com.aspose.pdf.Document;
com.aspose.pdf.facades.Form;

Please include those and release.

Hi Chamal,


Thanks for your feedback. As stated in your another post , we have passed on your concern to our product team for further investigation and rectification. We will let you know with the the updates asap.

Best Regards,

Hi Chamal,


I am sorry for the delayed response. Please note those packages are already have been exported in the Apose.Pdf for Java 10.4.0, please find attached screenshot. May be problem in spaces between the packages, so we have removed in later releases. Please download and try latest release and share the results.

Best Regards,