We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Arial Font Changed to Times New Roman when Converting PPTX to PDF

After running into some issues while using your Aspose.Slides Cloud API docker, I decided to try testing the python library instead, since it is a more recent version.

So far things seem to be working a little better, except for a font issue.
When converting the attached pptx (Aspose.zip (216.4 KB)
) using the python library, the first word in the first slide (“TEST”) is converted to the wrong font - “Times New Roman” instead of “Arial”. In the original pptx, the font for that word is “Arial (Body)”, I’m not sure if that’s related.

I tried various methods to fix this, without much luck.
I even tried setting default_regular_font to “Arial” to see if that would at least fix this specific case, but nothing changed. Setting embed_full_fonts to True didn’t help either.

Am I doing something wrong or is this yet another bug?

This is my code:

import aspose.slides as slides

pres = slides.Presentation("fontissue.pptx")
options = slides.export.PdfOptions()
options.default_regular_font = "Arial"
pres.save("PPT-to-PDF.pdf", slides.export.SaveFormat.PDF, options)

I should mention that when converting this file to PDF using the Cloud API, I did not encounter this issue.

Thank you for reporting the issue.

I’ve reproduced the problem with changing Arial font to Times New Roman and added a ticket with ID SLIDESPYNET-7 to our issue tracking system. Our development team will investigate this case. You will be notified when the issue is resolved.

It would be great if you could specify the following:

  • OS version/distribution where the code was executed
  • Python version you used

OS: Windows 10 Pro 64bit 21H2
Python version - 3.9

Thank you for the additional information. I’ve passed it on to our developers. We will do our best to resolve the issue.