Free Support Forum - aspose.com

Aspose 8.1.2 - allowing values with apostrophe in front of text

hi

we are using aspose 8.1.2 and we have values with apostrophe in front of the text. Now the properties getQuotePrefix or setQuotePrefix do not seem to be present in this aspose version with the Style, workbooksettings or Styleflag.

Can you please tell how I can get the apostrophe to come in the output.Basically it should display with the apostrophe not only in the cell value but also on display. No double single quotes should be present, no formula (please see the attached snapshot) apostrophe.JPG (4.5 KB)

Please note I have already tried the following: but they are not working:
https://docs.aspose.com/display/cellsjava/Show+leading+apostrophe+in+cells


https://docs.aspose.com/display/cellsjava/Preserve+Single+Quote+Prefix+of+Cell+Value+or+Range#PreserveSingleQuotePrefixofCellValueorRange-SampleCode

@chetan.mishra,
Thank you for your query.

Following is a sample code which sets sample data with and without a single quote in different cells. The Workbook.Settings.QuotePrefixToStyle is set to false and the output file is saved. Please give it a try using the latest version Aspose.Cells for Java 20.1 and share the feedback.

Workbook workbook = new Workbook();
workbook.getSettings().setQuotePrefixToStyle(false);
workbook.getWorksheets().get(0).getCells().get("A1").setValue("Hello");
workbook.getWorksheets().get(0).getCells().get("A2").setValue("'Hello");
workbook.save(path + "output.xlsx");

output.xlsx.zip (6.1 KB)

HI
Thanks but it has not helped me.

I have seen all these examples and even tried to experiment them.

My problem is that I use 8.1.2 , and I am not getting the “setQuotePrefixToStyle” method itself. Please understand that. I do not see the methods itself - otherwise would have seen the examples and used them.

I tried using:
workbook.getSettings(). -> this does not have the method “setQuotePrefixToStyle”
style. -> this does not ahve the method “setQuotePrefix()” itself
I tried using styleflag example also. it does not help.

I was trying to understand if 8.1.2 version first supports or not? If not then I need to know if we have to upgrade because the license we have but we cannot just upgrade the version without proper and lengthy approvals.

So, without going in that direction I was trying to see if 8.1.2 will help or not.

Please see the attached screenshot - I do not get that method itself

aspose_8_1_2_does_not_have_method.png (23.4 KB)

@chetan.mishra,
Yes, you are right that this method is not present in version 8.1.2. You may please upgrade to the latest version 20.1 for using this feature. I am afraid that upgrades are not provided for older versions, therefore it is not possible to use it with the version which you are currently using.

hi 17.12 does it have the fix- because we have recently puchased that.

@chetan.mishra,

I am afraid upgrading to 17.12 won’t help. We are sorry but the methods, i.e., setQuotePrefixToStyle and setQuotePrefix has been added a few months ago. In short, there is no alternative but to upgrade to latest APIs set.

Amjad, please give the version from when it has been added.

@chetan.mishra,

We are not completely sure when these attributes were added but I guess these attributes were there in v19.9 or greater versions.