We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Aspose Cells and dom4j-1.6.1

We have an issue where we have another 3rd party product, Cognos (from IBM), which uses an older version (1.0) of the dom4j jar. They will not support the newer dom4j anytime soon.

Trouble is, the classes in dom4j 1.0 are named the same as those in 1.6.1. So there's a fundamental conflict when you try to run Cognos and Aspose Cells in the same JVM, since they each require different levels of dom4j. This is effectively making Cells difficult, if not impossible, for us to implement.

Is there any way to get a version of Aspose that uses the older dom4j? Or get it to use the 1.6.1 version of dom4j using a different package structure? Help!

Hi,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

We have added your request in our internal issue tracking system with issue id: CELLSJAVA-17042. We will investigate your issue and get back to you soon.

Thank You & Best Regards,

I work with Don. It turns out IBM Cognos only uses dom4j for some “toy demo programs” and dom4j is not actually required to run IBM Cognos SDK. So we are “good to go” on using Aspose & dom4j-1.6.1. You can close this ticket.