Free Support Forum - aspose.com

Aspose.Cells Classic ASP

Hi,

I have been using various ASPOSE components for the last few years. I am well versed in exposing components to COM.

About 2 days ago all the components on our server ceased to work through ASP. The current error message is shown below:

Server object error 'ASP 0177 : 8000ffff'

Server.CreateObject Failed

The offending line is:

Set xls = server.CreateObject("Aspose.Cells.Workbook")

I have already spent a few days trying to fix this error with no luck. I am using Aspose.Cells version 4.1.0.9. I realise that this is an old version, but we chose to stick with this version due to the ever-changing overload functions (We were having to change functions with each release). This version of the component has worked fine over the last year without any problems. I have already tried the following many times over and in many different orders.

Uninstalling/reinstalling the component.
Regasm of the component (in both version 1.1 and 2 of the framework)
IISRESET
Uninstall/Reinstall of IIS
Uninstall/Reinstall of .NET version 2 amd 3

No combinations of the above has worked and now I am at a complete loss.

I have created a VBS file to mimic the creating of the object and this executes without any errors at all - but the same line in an ASP page does not work.

Please can you help me.

thanks,

Greg Pakes

Hi Greg,

Please check the following for your issue:

http://forums.iis.net/t/1031422.aspx

Thank you.

Thanks for your help but, I could find very little on that page of any help whatsoever.

I have installed the newest version of the component and simply through the MSI installer it works perfectly. Do you know of any reason that the old MSI is not working?

FYI - The new version of aspose.cells that WAS working is now no longer working. All I did was change a totally different website in IIS to use version 2 of the .net framework....

I went into IIS - right click --> properties (of a seperate website) --> ASP.NET and changed the version to 2. The excel component no longer works.

Greg

After a little more experimenting - I am now in teh following situation.

I have two IIS websites.
Both sites have access to the Excel Component.
On a fresh install of Aspose.Cells

  • Site 1 works as expected
  • Site 2 generates the error shown in post 1
  • NB. Both sites use the exact same code (one is for internal traffic and one is for external traffic)

any ideas?

Hi,

Normally, when you use MSI installer to install the component, the library also gets registered related to the com libraries on the machine. Does the older Aspose.Cells version works fine on your second server if you install on it.

I think you may try to do on Site 2:

1. Unregister the component using commandline i.e., Regasm /unregister Aspose.Cells.dll first.

2. Now register the component using Regasm /codebase Aspose.Cells.dll.

Thank you.

I will try the above - but surely an uninstall will do all this automatically...

I'm not sure I was clear but the scenario I posted above with the two IIS websites is on one single server. I have two websites running on the same server and accessing the same code. This is why I find it so confusing.

Greg

I think it must be a configuration problem. Please check what's the difference in your two websites' settings. Please assign same rights for both of them.

FYI -

regasm ... /unregister

regasm ... /codebase

Solves the problem temporarily. I have got into work this morning and site 1 that was previously working - is no longer working. Running the commands above solve it (but for how long).

I have checked the IIS configurations and they are both 100% identical. There are no differences whatsoever. I have found a short term solution - namely, I have created a batch file which runs both regasm commands every 30 minutes. This is clearly not a permanent solution.

I really appreciate your help.

Greg

Hi Greg,

Aspose.Cells is a pure .net component so I am also very confused with this problem.

From my past experience, sometimes windows patches may also bring weird problems.

Laurence,

I too am confused. Do you know of any tools that will enable me to see exactly what is exposed to the COM?

Or do you think the easiest solution would be a complete rebuild of the server (may save us both some time and a headache).

thanks,

Greg

Hi Greg,

Actually I am not proficient in COM/ASP. But I have some thoughts:

1. After you install Aspose.Cells, you will find two version in bin folder, one for .net 1.0/1.1 and on for .net 2.0. If your server runs on .net2.0, you can try to use the version 2.0 dll.

2. I don't suggest to rebuild your server for it's a time consuming action. Maybe you can deploy your whole application in another machine and run it. That will help you to make the decision if you need to rebuild your server.

3. You can try to write a .net wrapper class to hide all calls to Aspose.Cells. Your ASP program just calls your wrapper class. This may also help you to find the cause of problem and make it easy to develop your ASP application.

Laurence,

Thanks for all your help. I really do not know what is going on - but suddenly another development server of ours now exhibits the same problem.

Again - an /unregister and a /codebase resolves the issue in the short term.

Now I am really confused.

Greg

Hi Greg,

Have you made some changes in your development server, such as rights change or installing windows patches?

The only possibility is a windows update. Nothing else on the server has changed that would be relevant to this.

I am however reluctant to admit that it is a windows update as the only update that has been installed recently is an update to change daylight savings time. Namely, KB933360.

I doubt this update is relevant. I'm still confused. Again, i've got into work today and the components are no longer recognised. This time - the solution was to regasm /unregister and /codebase both the net2.0 and net1.0 directories. Before I only had to do it on the net2.0 folder.

any ideas?

Greg

Hi Greg,

Is it possible that your application crashed which causes this problem? And does this problem happen on your IDE?

I searched on google and find this is a really common problem but I don't know why it happens with Aspose.Cells. No other user reports this issue before.

Laurence,

I do appreciate your help. I am looking into the issue and will keep you posted with what i find out.

thanks,

Greg

I am now getting somewhere with this issue. After a few weeks of paid microsoft support we have found out the problem and a work around.

The problem is due to an IE7 update. The update changes the permissions on some keys in the registry. The solution is as follows:

Allow Everyone Read access to:

HKEY_USERS\S-1-5-20\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones

This does indeed resolve the issue. MS are getting many requests regarding this problem and will (hopefully) release a hotfix shortly.

I hope this helps some people.