We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Aspose.Cells.GridDesktop

I am trying to work out how to preview a spreadsheet. Per the documentation, I should be able to use the Aspose.Cells.GridDesktop dll. Except that I don’t have it, and have been unable to find it anywhere on the site.

Please let me know where I can find it.

Hi,

Thanks for your posting and considering Aspose.Cells.GridDesktop.

Please download and install the latest version:
Aspose.Cells for .NET 8.7.0 and then check the installation directory. Please search for Bin directory inside the installation directory and you will find Aspose.Cells.GridDesktop.dll inside the Bin\net2.0 directory.

OK. I see it now. I am using the .NET Framework 4.0 dll. Should I change it to the .Net 2.0? My application is 4.0.

Hi,


No need to change your .NET Framework version of your application/project, Aspose.Cells.GridDesktop (from .net2.0 folder) would work equally fine on any .NET framework version >= 2 (i.e., 2.x, 3.0, 3.5, 4.x or above).

Thank you.

Thanks for that.

Now I have a problem that I need your help solving with this.

Now for some reason the cells that are formulas don’t work. I have changed the properties of the viewer RecalculateFormulas to true and AlwaysRecalculateAllFormulas to true, and it still doesn’t do anything.

Hi,


If you want to retrieve calculated values (against formulas) from the cells in your code dynamically at runtime after updating the source cells in the worksheet, you may try to call GridDesktop.RunAllFormulas() method before obtaining the updated values.

If you still find any issue, kindly provide more details and create a separate WinForm application (runnable) with v8.7.0 (GridDesktop), zip the project and provide us here, we will check it soon.

Thank you.

OK. I have that all working now.

The next problem is this:

If you merge two cells, and put a formula in it, the formula doesn’t work, and the value doesn’t display. If I remove the merged cell, it displays.

The other thing is that I have check boxes in the spreadsheet that if clicked change the formulas. The check boxes are disabled and can’t be changed. How do I enable them?

Hi,


Thanks for providing us some details.

I have evaluated your scenario/ case a bit. I could not find the issue using our latest version/fix: Aspose.Cells.GridDesktop v8.7.0. I inserted some values into a few cells and make A4:B4 cells merged to make it A4 cell. Now I inserted a Sum formula to it (A4 - merged cell), it works fine. See the screenshots for your reference:
http://prntscr.com/a1clhi
http://prntscr.com/a1cln7

Regarding your other issue for CheckBoxes, well, Aspose.Cells.GridDesktop control renders the Forms controls as images into its grid matrix. Anyways, could you provide us a sample project (WinForm application) with v8.7.0 (GridDesktop), zip the project and post us here, we will check and may log a ticket for your requested feature if we could support it. Also attach your template Excel file here.

Thank you.

Hi,



Attached is the spreadsheet I am having problems with. You will see the problem with the merge is with cell B27. Any data entered into B27 vanishes, and the formula on I27 doesn’t populate. I27 is also a merge field.



The checkbox is on J50.



Regards

Robert

Hi,


Thanks for the template file.

Well, your underlying worksheet(s) is protected, so you cannot insert values or calculate formulas on the cells (you cannot do this even in MS Excel without unprotecting the sheet). Also, Aspose.Cells.GridDesktop does not support to unprotect worksheets at runtime, so you got to unprotect the worksheets in the workbook and re-save the file in MS Excel and then use Aspose.Cells.GridDesktop to open into it.

Regarding CheckBoxes issue, as I told you that Form controls in MS Excel are rendered as static images in Aspose.Cells.GridDesktop, this feature is not supported. Do you need us to log a new ticket for it?

Thank you.

Although the spreadsheet is protected, everything in yellow is editable. You can change the values. Just not on the Merged cells.

Hi,


Yes, we can insert/edit values in the simple cells but not on Formula cells. You cannot edit or calculate formulas cells in the protected sheet, you may confirm this behavior in MS Excel too. So, you got to unprotect the sheet if you need to edit or calculate the formulas. Do you only need to insert/edit values to simple merged cells (e.g B27) even if the worksheet is protected (by Aspose.Cells.GridDesktop)?

Thank you.

It looks like I know this product better than yourself.

The spreadsheet works fine. You can enter data. Your formulas do not automatically work. This is a bug on your side. You have to call the function RunAllFormulas() on the event CellDataChanged. That is the only way that the formulas will work, regardless of if it is protected or not. So the formulas do work. But not on a cell that has been merged. If you open the spreadsheet normally, you will see if you enter data into B27, it goes across to I27. But not when you open it in the viewer.

Hi,


I have tried your scenario/case a bit. I unmerged the B27 cell first, then I put some value in B27 cell in “Calculation” sheet and then press enter (I already have called GridDesktop.RunAllFormulas() in CellDataChanged event handler). I could not see any calculated values in other cells e.g I27. The cell(s) still show “-” (I also cannot remove formatting on the cells as the worksheet is protected). We appreciate if you could capture a demo video of the steps while running the scenario or performing your task on your side and attach it here, so we could reproduce the issue on our side. Also which Aspose.Cells.GridDesktop version you are using?

Thank you.