We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Aspose Cells - Slicers from pivot table basefields is not working

Currently building a simple workbook from a csv file . on a 2nd worksheet adding a pivot table with the range of data from 1st worksheet. when try to add 2 slicers from the PivotTable basefields the .xlsx created throws the attached photo error. SlicersError.PNG (3.2 KB)
Used the same approach as per your documentation: https://docs.aspose.com/cells/net/create-slicer-to-a-pivot-table/
I attach below a sample console app: the method is: CreateSlicers() ; input csv (in project dir): LA_SUM.csv and output report will be: SlicersOutput.xlsx . We’re using Aspose Cells 21.5.0
SampleProject1.zip (283.1 KB)


Please notice, I am able to reproduce the issue as you mentioned by using your sample project with your CSV file. I confirmed the issue, i.e., when we add 2 slicers from the PivotTable (basefields), the output XLSX file (created) crashes MS Excel and throws your mentioned error in MS Excel. It works fine if we add only one slicer based on the pivot table. I have logged a ticket with an id “CELLSNET-48365” for your issue. We will look into it soon.

Once we have an update on it, we will let you know here.

Even if you add one slicer with some basefields is working and with others is not working.I tried with few random columns: (tried both with Basefield name and index): LA_Name, LA_Code - working; Year, CycCas - Not working.
Throws the same error and then crushes.


Thanks for your findings. We have recorded it with your existing ticket into our database.

Once we have any new information available, we will update you here.

Any updates yet for the ticket?
Thanks for all the hard effort.


Apparently, the issue is fixed but still we need to evaluate certain aspects. Hopefully we will get back to you soon (within the next few days) with updates and possible fix on it.

ok. Thanks for the feedback


You are welcome.


Please try our latest version/fix: Aspose.Cells for .NET v21.7.4 (attached)
Aspose.Cells21.7.4 For .Net2_AuthenticodeSigned.Zip (5.5 MB)
Aspose.Cells21.7.4 For .Net4.0.Zip (5.6 MB)
Aspose.Cells21.7.4 For .NetStandard20.Zip (5.6 MB)

Your issue should be fixed in it.
Let us know your feedback.

Just tested and is partially fixed. It allows to create multiple slicers but for any BaseField name that contains:
it throws the error attached in picture. To replicate the error just add one of the characters mentioned in any of the column titles from the feeding file (LA_SUM.csv) for example: “LA Name” or “All%Acc” or “All/Cas”
I’ve tried to add by baseField index or try few string format tricks but doesn’t workSlicer_FieldName_Error.PNG (16.1 KB)


You are right. I got the exception if any BaseField name that contains your mentioned characters. I have reopened the issue and we will look into it soon.

The issues you have found earlier (filed as CELLSNET-48365) have been fixed in this update. This message was posted using Bugs notification tool by simon.zhao

Great! is the .dll released yet?


Yes, sure, you may download the Dlls version and get your desired Dlls of Aspose.Cells for .NET APIs for your needs. Alternatively, you may import the release package from Nuget repos. and get your desired Dlls.

Thanks. Will give it a go shortly


You are welcome. Take your time to test the new release.

Hi Amjad ! Just tried to download the dll and it directs me to the doanload page, but when press the download just screens a blank page without downloading the dll. I’ve tried on both G.Chrome and M. Edge with no luck. Also tried to download other dll (prev version) just as a test and has the same behaviour (doesn’t download), this probably meaning that something might have to do with my account.


You need to log in to download to Dlls version. Also, after you got the blank screen/page then you will finally get Download page (after some time) again where will again click “Download” button. It works absolutely fine on our end, see the screenshot (attached) for your reference.
sc_shot1.png (70.9 KB)

Alternatively, you may download the Dlls from Nuget repos. (as we told you in previous reply). In your VS.NET project, Go to “Tools|Nuget Package Manager”, then either use Package Manager Console or “Nuget Packages for Solution…” option to download/import to your solution.

Let us know if you still have any issue with downloading the Dlls.

The fix is working fine. Thank you!

You are welcome.