We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Aspose cut off background picture

Hello!

Discovered the following problem with aspose.slides. I have a presentation with a picture in the background. When I convert the slide in the image with slide.getThumbnail(), the background image is cut off. In version 2.9.6 it works, but since 3.0.0 the problem occurred. Can you help solve it. The presentation is attached.

Thanks!

Hi Артём,


Thanks for your interest in Aspose.Slides.

I have observed the image shared by you. Can you please try using Aspose.Slides for Java 6.7.1 on your end and if there is still an issue then please share your feedback with us.

Many Thanks,

The problem is reproduced in versions 3.0.0, 6.7.0 and 6.7.1.

Hi Артём,


I have worked with the presentation file shared by you using following sample code by referencing Aspose.Slides for Java 6.7.1 on my end. I have not been able to reproduce the issue on my end in Windows Environment. Can you please try using the following sample code in your environment. If there is still an issue then please share the complete environment details with us where by you are reproducing the issue along with JDK version.

public static void GenThumbnail()
{
String path=“D:/Aspose Data/”;
//Instantiate a Presentation object that represents a PPT file
Presentation pres = new Presentation(path+“pres.ppt”);

//Accessing a slide using its slide position
Slide slide = pres.getSlideByPosition(1);

BufferedImage imgq = slide.getThumbnail(2f, 2f);
try {
ImageIO.write(imgq, “JPEG”, new java.io.File(path+"\Slides\Slide_"+Integer.toString(i)+".jpeg"));
} catch (IOException e) {
e.printStackTrace();
}

}

Many Thanks,

Hi, Mudassir!

Your code works perfectly. When I set my parameters slide.getThumbnail (new Dimension (999, 749)), the error appeared again. It is interesting that slide.getThumbnail (new Dimension (1000, 750)) works correctly.

Thanks!

Hi Артём,


I have worked over the custom dimensions shared by you and have been able to reproduce the issue specified. An issue with ID SLIDESJAVA-33658 has been created in our issue tracking system to further investigate and resolve the issue. This thread has been linked with the issue so that you may be automatically notified once the issue will be resolved.

We are sorry for your inconvenience,

The issues you have found earlier (filed as SLIDESJAVA-33658) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.