Free Support Forum - aspose.com

Aspose Doc Exporter Plugin Returning Blank Documents

Hey,


I successfully installed and activated the Aspose Doc Exporter Plugin today, and created an Aspose account to obtain the App SID and key. I entered these in the settings, hit save, and proceeded to my posts library. I sorted the library by category and looked only at published posts. I then checked all the posts I wanted and selected “Aspose Export to File” as the bulk action, and hit Apply.

I am running Windows 8 and using Google Chrome, so the download appeared immediately at the bottom of the window. I opened it, only to find that the file was completely blank.

I tried regenerating the key, reentering all of the information. I combed through the instructions and watched the instructional video to ensure I had missed nothing. Consistently, the plugin generated a blank document.

Incidentally, I tried Aspose Pdf Exporter as well, which produced a 500 error every time I tried to use it, even after I had entered the App SID and key.

Please, if anyone can help, I could really use this plugin!

Hi,

The plugin is working fine at our end and we were not able to reproduce the issue. We will be able to further investigate if you can give us access to your blog. Will it be possible for you?

Best Regards,

I can’t give you access to the blog, but I can give you information from our server. My colleague tells me that the error is in the plugin, not on our end.


016/01/29 14:06:01 [error] 2341#0: *101119 FastCGI sent in stderr: “PHP
message: PHP Fatal error: Uncaught exception ‘Exception’ in
/srv/www/h20-wp/wp-content/plugins/aspose-pdf-exporter/Aspose_Cloud_SDK_For_PHP-master/src/Aspose/Cloud/Common/Utils.php:116

Stack trace:

#0
/srv/www/h20-wp/wp-content/plugins/aspose-pdf-exporter/Aspose_Cloud_SDK_For_PHP-master/src/Aspose/Cloud/Pdf/Document.php(140):
Aspose\Cloud\Common\Utils::processCommand(‘http://api.aspo…’;, ‘PUT’, ’’,
’’)

#1
/srv/www/h20-wp/wp-content/plugins/aspose-pdf-exporter/asposePdfConverter.php(49):
Aspose\Cloud\Pdf\Document->createFromHtml(‘output_14540943…’,
‘output_14540943…’)

#2
/srv/www/h20-wp/wp-content/plugins/aspose-pdf-exporter/aspose_pdf_exporter_admin.php(171):
include_once(’/srv/www/h20-wp…’)

#3 [internal function]: aspose_pdf_exporter_bulk_action(’’)

#4 /srv/www/h20-wp/wp-includes/plugin.php(525):
call_user_func_array(‘aspose_pdf_expo…’, Array)

#5 /srv/www/h20-wp/wp-admin/admin.php(342): do_action(‘load-edit.php’)

#6 /srv/www/h20-wp/wp-admin/edit.php(10): require_once(’/srv/www/h20-wp…’)

#” while reading response header from upstream, client: 173.161.47.77,
server: handshake20.com, request: “GET
/wp-admin/edit.php?s=&post_status=all&post_type=post&_wpnonce=43210a9660&_wp_http_referer=%2Fwp-admin%2Fedit.php&action=aspose_export_pdf&m=0&cat=0&paged=1&post%5B%5D=9143&action2=-1
HTTP/1.1”, upstream: “fastcgi://127.0.0.1:9000”;, host: “www.handshake20.com”;,
referrer: “http://www.handshake20.com/wp-admin/edit.php”;

Hi,

Can you please confirm which PHP version are you using? You must be using PHP 5.3 at least, in order to use the plugin.

Best Regards,

We’re on PHP 5.5.9. Are you saying your plugin is not up to date?

Hi Laurel,

Sorry for the confusion. The plugin is working with 5.3 and later versions of the PHP. It may not work with the older versions. You are using later than 5.3 version so there should not be any issue at your end.

For your particular issue, your cooperation will be required to investigate the issue in detail. Access to your blogs was one of the options but as you shared earlier, it is not possible for you. Second option is to get in touch with our representative from plugins team via a chat session and show your issue via screen sharing etc. Can you please share your timings and Skype ID if this option is feasible for you?

Best Regards,

I am experiencing the same issue as described by the initial problem report. If I cannot get this resolved, I may have to uninstall the plugin.

Can you please post the solution (in detail) to the above problem?

Thank you,

-Kathleen

@kathleenwest,

Thanks for your inquiry. We have created a new thread in Aspose.Total for Cloud forum. Please follow this thread for further proceedings.