We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Aspose does not support Field flattening in append mode

when a pdf file’s page number doesn’t match the real page number. (using copy paste to generate a pdf file) the api call failed with 'Aspose does not support Field flattening in append mode’

please see atached image file. thank you

Hi There,


Thanks for contacting support.

We will really appreciate if you can share more details i.e sample code snippet and sample PDF file, so that we can further look into this and update you accordingly. We are sorry for the inconvenience.

Best Regards,

ok, i attached 7 file. let me know if you have any questions.
(the best solution is if the API can return the error message to address the specific error
not the general error cannt flatten the file…)

0. our license.
1. the code snippet to call aspose API to concatenate PDF files.
2. error message
3. restrict changing document pdf file
4. wrong page count pdf file.
5. restrict changing document image
6. wrong page count image

thank you very much for you helps.
this is not an urgent issue but we really like it is solved :slight_smile:



Hi Alex,


Thanks for sharing the details.

I have tried replicating the issue using earlier shared code snippet but I am afraid there are many undefined variables (dvApplicant, EJMLabel etc), so I am unable to test the scenario. Can you please share some sample project and also please share some details regarding the operation which are trying to accomplish with these documents.

PS, based on some routines called in your code snippet, I have tried flattening the PDF files and also have tried concatenating pages of both documents (using new DOM approach), but I am unable to notice any issue.

[C#]

Document doc = new Document(“c:/pdftest/4-wrong-page-count.pdf”);<o:p></o:p>

doc.Flatten();

Document doc2 = new Document("c:/pdftest/3-restricted-changing-document.pdf");

doc.Pages.Add(doc2.Pages);

doc.Save("c:/pdftest/4-wrong-page-count_Flatten.pdf");

thank you very much. will get you back soon.
i will do some more tests on my end using the way you mentioned.

ok. i downloaded the new Aspose Total package. and then
i coded a simple windows form test file (used your example) and it worked flawlessly. i believe we were using old way to flatten the pdf files and it caused the issues.

i attached the form1.cs (i renamed it to new_test_file.txt) along with test pdf/word files.

thank you for your helps. it can be closed for now. i will correct our codes and redeploy it.

Hi Alex,


Thanks for sharing the feedback.

We are glad to hear that your problem is resolved. Please continue using our API and in the event of any further query, please feel free to contact.