We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Aspose.Email Not Recognizing License - Acting Like Trial Version

Hi,

Problem: I cannot get Aspose.Email to recognize that I have a valid license installed and set. It keeps sending emails with "(Aspose.Email Evaluation)" appended to the subject line of emails I send.

The application is a Windows Forms .Net 3.5 application which until a few days ago was using Aspose.Words to create emails which were sent using Aspose.Network.

The application was using an Aspose.Total.lic which was

I am using a valid Aspose.Total.Product.Family.lic which expires 20121219 (12/19/2012).

I am setting the license, along with the Aspose.Words license like this:

Aspose.Words.License license = new Aspose.Words.License();

license.SetLicense(“Aspose.Words.lic”);


Aspose.Email.License emailLicense = new Aspose.Email.License();

emailLicense.SetLicense(“Aspose.Email.lic”);



The Aspose.Words license seems to be fine because it is creating the emails as
it did before.



I have not edited the license file.



I am using

Aspose.Email for .NET 1.2.0
which was released on 12/4/2011.



I have verified that I installed the Aspose.Total.Product.Family.lic as an
embedded resource.



Things I’ve tried:


  1. Installed an older version of Aspose.Email.
  2. Reinstalled the license.
  3. Tried setting the license to “Aspose.Total.Product.Family.lic”
  4. Cleared all application cache.


    Mike McIntyre MVP

Hi Mike,


We apologize for your inconvenience.

Please give a try to our latest version of Aspose.Email for .NET v1.3.0. If your problem persists with latest assemblies then please send us your license file for our review To send us the license, please use the “Contact” button on this thread, then select “send babar.raza an email”.

Thank you,

Hi Mike,


Thank you for providing the license file.

I am afraid that I am unable to replicate the said problem at my end. Your license is valid and I am able to use the Aspose.Email for .NET component in registered mode with it. I have tested the said issue by setting the license via file path, stream and embedded resource, as mentioned in this article.

Please find the attachment for a Windows Forms .NET Framework 3.5 sample project. I have sent an email to your account by executing the attached project. The Aspose.Email for .NET v1.3.0 assembly is present in the bin folder. Please place the license file in bin folder, update the credentials for SmtpClient and test it at your end.

Regard,

FYI I never received the test email you sent.

I see the example project includes LicensingWfa35 files - something not present in my Visual Studio 2008 solution. Ae these required?

Hi Mike,


We are sorry for any inconvenience caused.

I have sent a test email at "mikemc@getdotnetcode.com" using the sample project attached to my last reply. I can confirm that I have received a reply as well on the return address provided in test message.

Attached to this post is a sample project built with Visual Studio 2008. You can either add the license as an Embedded Resource or simply paste it in the bin folder of attached project. Hopefully, you will be able to execute it just fine.

Hi,


Are you able to resolve your licensing problem with Aspose.Email for .NET?

I came across a similar post in Aspose.Email forum. The issue was resolved by re-compiling the complete project after adding the references to latest assembly of Aspose.Email for .NET v1.3.0.

I hope this may help.
Regards,

Yes thank you, I just resolved the issue.

The problem was not with the Aspose license or Aspose.Email.

The problem was at my end. I tried reusing too much of the Aspose.Network code that was already in this 3.5 legacy application.

I rewrote the two functions involved from scratch and the issue was resolve.

Thank you for the help.

Mike McIntyre [MVP]