Free Support Forum - aspose.com

Aspose excel is converted to PDF. The images in excel are only a few tens of kilobytes, turning into PDF images into thousands of kilobytes

Please tell me Aspose.Cells can call PDF995 printing when transferring PDF file. Cells transfer PDF to enlarge the image in the document. After testing Excel to PDF. It’s going to add a big black background to the picture. As the picture grows larger, so does the PDF. If it’s a PDF printed out of PDF995, the comparison will be hundreds of times different.

            Dim WorkFolder As String = rc.TempPath
            Dim WorkFileName As String
            WorkFileName = WorkFolder & "\\" & Path.GetFileNameWithoutExtension(fileName) & ".pdf"
            WorkFileName = WorkFileName.Replace("(", "_").Replace(")", "_")
            excelApp = New Workbook(fileName)
            Dim xlsSaveOption As Aspose.Cells.PdfSaveOptions = New Aspose.Cells.PdfSaveOptions()
            xlsSaveOption.SecurityOptions = New Aspose.Cells.Rendering.PdfSecurity.PdfSecurityOptions()
            xlsSaveOption.SecurityOptions.ExtractContentPermission = False
            xlsSaveOption.SecurityOptions.PrintPermission = True
            xlsSaveOption.SecurityOptions.OwnerPassword = rc.OwnerPassword
            xlsSaveOption.AllColumnsInOnePagePerSheet = True
            xlsSaveOption.EnableHTTPCompression = True
            excelApp.Save(WorkFileName, xlsSaveOption)

@wengyeung,

Aspose.Cells for .NET has its own implementation of printing a file and a third party routine can not be used for printing with Aspose.Cells. Please attach source and output files for our reference so that it can be investigated further.

Uploading…
116/5000
Attached is the test I did. PDF is turned out with Aspose. Other tools go to PDF_864293. PDF is made with Other tools. The difference between the two files is huge. Please help to solve whether there is a good solution.
Afraid the attachment upload failed
The attachment is on cloud disk :http://note.youdao.com/noteshare?id=b01f094f2aaabe004b344ca45b3b6bbf

@wengyeung,

We were able to observe the issue but we need to look into it more. We have logged the issue in our database for investigation and for a fix. Once, we will have some news for you, we will update you in this topic.

This issue has been logged as

CELLSNET-46275 – Large PDF created from XLS

When can I expect a solution for this issue

@wengyeung,

As we just logged the ticket, so could you spare us a little time (3-5 days or so) for complete evaluation and investigation for your issue. If it is not much complex, you should be receiving the fix before the end of next week or even before it. If the issue is complex, it might take a couple of weeks.

Once we have an update on it, we will let you know here.

Ok, thanks! I’m waiting for your good news.

@wengyeung,

You are welcome.We will let you know once there is any update.

@wengyeung,

Please try our latest version/fix: Aspose.Cells for .NET v18.7.6:

Your issue of large PDF file generation should be fixed in it.

Let us know your feedback.

Hello, the files provided can not be downloaded. Please send it to my email. zhisheng.liu@symbio.com

@wengyeung,

I tried to download the above file from Dropbox and observed no issue. However for your convenience I have uploaded the file again on Google Drive. Please try to download the file from the following link and share the feedback.

https://drive.google.com/open?id=1tjm26HtRQ6_uBDrLXgVmtgAktClc5XLw

Google Drive does not have over the wall access, when can provide China can access to download cloud disk. thank you

@wengyeung,

An email is sent with attachment (Aspose.Cells for .NET v18.7.6 fix) at your mentioned email id.

Let us know if you still find any issue.

I have tried to ask my colleagues abroad to download, the current aspose version is 2.0, can you provide 2.0 version

@wengyeung,

We have sent another email containing both DLLs and you can use it with .NET Framework 2.0 in your environment. Let us know your feedback.

NewAspose.png (9.1 KB)
Thank you For providing Aspose.Cells18.7.6 For.Net2 has solved the problem I encountered. thank you

@wengyeung,

Good to know that your problem is sorted out. Feel free to contact us any time if you need further help or have some other issue or queries, we will be happy to assist you soon.

The issues you have found earlier (filed as CELLSNET-46275) have been fixed in this update. This message was posted using BugNotificationTool from Downloads module by Amjad_Sahi