We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Aspose-generated XLSX files opening with error

Hello,

I’m currently tasked with assessing requirements for a project to convert some of our reports, which are in SpreadsheetML format, into Excel XLSX format. And so I have found your product, which I was able to incoporate very easily, but I am having one issue, which is that when the XLSX file is opened, I get an error by Excel saying that the file needs to be repaired. After I click OK, it repairs successfully, and the resulting file matches exactly the original spreadsheetML format. The error log in excel doesn’t really tell me much other than that stuff has been repaired/discarded (no info on exactly what got modified).

I tried doing so using both the trial version, and the full version of Aspose.Cells w/ a temporary license. And both have the same issue. I’m using the latest version downloaded from your site (21.11)

Is there any way to get past, or ignore this error?

Once this error is resolved, I’m pleased with the results of the conversion, so I can green-light the procurement of this product.

Here are the example files I’m working with… the *.xml file is the file I produce today, and can be opened in Excel without errors.

Example Files.zip (15.4 KB)

Here is the test code I’m using:

com.aspose.cells.License license = new com.aspose.cells.License();
license.setLicense(new java.io.FileInputStream(“c:\\process\\Aspose.Cells.Java.lic”));

FileOutputStream fos = new FileOutputStream(thefile.internalName());
Workbook wb = new Workbook(excelXmlFile.internalName());
// wb.getSettings().setAutoRecover(false); // I tried this with true/false and not specifying this
wb.save(fos, SaveFormat.XLSX);
fos.close();

“excelXmlFile.internalName()” returns the *.XML filename that’s a spreadsheetML file. “thefile.internalName()” returns the *.XLSX output filename.

Thank you for any help in advance,
Jay Horita

@imkookoo
We have reproduced this issue and logged it in our database for further investigation. You will be notified here once any update is ready for sharing.

This issue is logged as:
CELLSNET-49924 - Aspose-generated XLSX files opening with error

@imkookoo
Please try the latest fix 21.11.6.
Aspose.Cells21.11.6 For .Net2_AuthenticodeSigned.Zip (5.6 MB)
Aspose.Cells21.11.6 For .Net4.0.Zip (5.6 MB)
Aspose.Cells21.11.6 For .NetStandard20.Zip (5.6 MB)

Hi Simon,

Thank you for the quick turnaround!

Do you have a link to the Java version of the fix?

@imkookoo,
Please try our latest fix of Java version:
aspose-cells-21.11.7-java.zip (7.5 MB)

Thank you! I tried it out, and verified that it has resolved the issue. I’ll test out a few other reports on my system, and then give my CEO the go-ahead and let him know support for this has been quick as well.

Best regards!

@imkookoo,

Please take your time to evaluate the new fix for your scenario/case. Hopefully, it will pass all your test cases or scenario.