We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Aspose GridWeb capabilities

Hello,

I am trying to get a webgrid worksheet to display embeded images, graphs and data so that the user can edit and update data, charts and images. I am trying to make sure that WebGrid is capable of displaying the embeded images in addition to the data and charts. Currently the images embedded in the excel spreadsheets (.xls) are not showing in the browser view for us in Chrome Version 36.0.1985.125 m. and IE version: 11.0.9600.17207.


A javascript exception is being thrown via browserLink.js, but I believe it to be unrelated to Aspose functionality despite the target being a JavaScript runtime error: Syntax error, unrecognized expression: col#GridWeb1_!0C. I haven’t ruled this error out and am working through this, but cant tell if it’s related to the embedded images not displaying yet.


I am currently using Aspose.Cells.GridWeb v 8.1.2.2000 runtime version 2.0.50727.
We’re using .NET 4+


This message was posted using Banckle Live Chat 2 Forum

Just to update:


After looking into the information regarding browserLink, which does appear to be looking for a col tag that does not exist. In our case it appears to be looking for this col#GridWeb1_!0C. There are several and many col#GridWeb1_ iterations but none that seem to match the !0C ending. I can only find a col#GridWeb1_!0CD with the D being a missing factor in what the browserLink should be calling.

Hi Bryce,

Thanks for your posting and using Aspose.Cells for GridWeb.

Since, you are already using the latest version of Aspose.Cells for GridWeb, kindly provide us a simple one aspx page web application replicating your issue with the latest version.

Please also provide us screenshots highlighting your issue with red circles around the problematic area so that we could look into this issue precisely. We will investigate it at our end and then update you asap.

I have attached the zip of the VS Express 2013 single page solution. And a screen capture of the image that doesn’t show up. With the error that displays when browserLink is looking for col#GridWeb_!0C instead of col#GridWeb_0!CD.

Hi Bryce,

Thanks for your posting and using Aspose.Cells for GridWeb.

When I ran your project, GridWeb did not display the images in a worksheet. However, when I ran it in a standalone web application, it showed the embedded images but the same first worksheet image was displayed in all web worksheets. Please check the word document containing screenshots attached with this post.

Could you please download and try running the standalone web application project that I have attached, at your end and check the results?

We have logged this issue in our database for investigation. We will look into it and fix this issue. Once, the issue is resolved or we have some other update for you, we will let you know asap.

This issue has been logged

  • CELLSNET-42881 - GridWeb is showing same picture in all web worksheets

Hi Bryce,

Thanks for using Aspose.Cells for GridWeb.

We have fixed the issue. (CELLSNET-42881 - GridWeb is showing same picture in all web worksheets)

Please download and try the fix: Aspose.Cells for GridWeb v8.1.2.2001 and let us know your feedback.

The issues you have found earlier (filed as CELLSNET-42881) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.