We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Aspose.imaging java 1.6 support?

Is java 1.6 still supported for the latest aspose.imaging API? Just downloaded latest trial version and examples from github and it appears it requires java 1.7, am I correct?

Hi Bob,

Yes, All Aspose APIs (including Aspose.Imaging for Java) support Java 1.6 and above. Please test the API in a Java 1.6 application and let us know if you see any issue.

Best Regards,

Hi Bob,

In continuation of our previous response, this is to update you that Aspose.Imaging for Java API support Java 1.6 and above. The only difference is in TRY statement. Following are the details:
If you want to use following code structure only then you need Java 1.7.

try(Image img = Image.load("somefile"))
{
}
If you use following code structure then there is no need for Java 1.7.

Image img = Image.load("somefile");
try
{
// do something with img
}
finaly
{
img.dispose();
}

Hope the above information helps. Feel free to contact us in case you have any query or comments.

Hi Bob,

Thanks for the acknowledgement. We are glad to hear that your problem is resolved. Please continue using our API's and in the event of any further query, please feel free to contact.