We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Aspose.Network.Imap.ImapClient.ListMessages() hangs

Hi,

I'm running this code using Aspose.Network 5.0.0.0 on .NET2.0 (Windows Server 2003) against Domino IMAP4 Server Release 8.0.1HF1121:

ImapClient mailClient = new ImapClient(host, port, userName, password);

mailClient.EnableSsl = this.settings.UseSsl;

mailClient.Connect();

mailClient.Login();

mailClient.SelectFolder(folder);

mailClient.ListMessages();

The last line hangs on certain email messages.

If I change the call to ListMessage(1) it works (if there's a message in the folder).

Any ideas why this is?

Thanks

Hi,

Could you please tell us some more details below:

  • Does it hang when the selected folder has 0 messages?
  • Does it hang when the selected folder has 1 message? Could you please test by sending a simple text message.If it succeeds, try sending a complex message with attachments and html text.

We've used it for hundreds of emails, with a variety of attachments etc, and this is the first one that has failed. The failing email does so consistently on one mail server, but works on another (a different server type).

The email is HTML format and has one attachment, a 16KB PDF file, which has a faily long filename (about 100 characters) - not sure if that is relevant. The email itself looks pretty normal, opens absolutely fine in Outlook, it's 37KB including the attachment.

Let me know if there's any other information that would be useful.

Thanks for your help.

Hi,

Could you please try the latest version 5.1, which is just released. There was a related Imap issue which is fixed in this version (5.1).

If still you get the same problem, please reply and we will investigate further to track and resolve the issue.