We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

ASPOSE on SSRS 2008 R2 producing blank documents

Hello,

We just upgraded to SSRS2008 R2. After upgrade, we installed latest SSRS ASPOSE.PDF (2.3.1) and upon document generation we are getting blank documents (0 bytes). There is nothing captured in the event logs and no error comes up.

Server information:
Windows Server 2003 SP2
Enterprise 64-bit

---------------Exception when rendering report file--------------
Exception Message:
Object reference not set to an instance of an object.
Calling Stack Trace:
at xa58baeaa59f3b03e.x68ca9ee746cddea0.x9f6bbfd6a9013899(Style
x2abaaca9e5e4d59f)
at Aspose.Pdf.ReportingServices.Renderer.x3c17e966883bbe6f(Report
x64343a0786fb9a3f, NameValueCollection x4d7e972a483f38e6,
NameValueCollection x769338e163ee6eb4, NameValueCollection
x69ea43ef171861cd, Hashtable& xcc726f61cfb91835, CreateAndRegisterStream
x6af66da7eca40f82)
at Aspose.Pdf.ReportingServices.Renderer.Render(Report report,
NameValueCollection reportServerParameters, NameValueCollection deviceInfo,
NameValueCollection clientCapabilities, Hashtable& renderProperties,
CreateAndRegisterStream createAndRegisterStream)
----------------------End of Logging---------------------

Thanks

Vlad

Hi Vlad,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thank you for sharing the details.

We have registered your issue in our issue tracking system for further investigation with issue id: PDFREP-31737. We will look into your issue and get back to you soon.

Sorry for the inconvenience,

Hi Vlad,

Adding more to Nausherwan's comments, can you please share the source .RDL document so that we can test the scenario at our end.

Attached example of the rdl that fails to generate. Thanks

Hi there,

I'd like to escalalte this issue. This is causing us some serious delay at this point. May I please get an estimate on when you'll complete the review of this issue?

Thanks

Vlad

Hi Vlad,

Thank you for sharing the RDL file.

Our development team is looking into your issue and as soon as there is any feedback regarding your reported issue, we will be happy to share it with you. Please be patient and give us a bit more time to look into your issue. Also, I have requested the development team to share an ETA regarding your issue.

Sorry for the inconvenience,

Dear ASPOSE team,

Do you have any SLAs for issue resolution? I fail to understand why there are no updates for over two days now. Have I not indicated that this is an urgent matter? Please let me know where we stand in resolving this issue.

Thanks

Vlad

Hi Vlad,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Please accept our apologies for the inconvenience.

We understand that this issue is a critical / urgent issue at your end that is why we are treating this issue as a high priority issue at our end too. Our development team is investigating your issue and as soon as I get any feedback, I will update you. As far as the timeframe for resolution of issues is concerned, we try to resolve the issues as quickly as possible but this also depends on the complexity of the issue. Please be patient and give us some more time to look into your issue.

Sorry for the inconvenience,

Hi Nausherwan,

Is ASPOSE going to provide an update for this issue? This is truly getting out of hand. Again, I ask you, what is your SLA on issues resolution? This can go indefinitely for all I know. Can you at least provide an estimate on when this will be looked at? Quite frustrating.

Vlad

Hi Vlad,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Sorry for the inconvenience, I understand that this is an urgent issue and that is why we have set the priority of this issue as high at our end as well. To update you regarding your issue, our development team is looking into this issue and this issue is included in current week's weekly plan for investigation / resolution. Hopefully, we will provide you our complete feedback regarding the issue by the end of this week. Please spare us sometime to further look into your issue and resolve it.

Sorry for the inconvenience,

May I please get a status update on this issue? Just to confirm, your SLA for all issues resolution is not defined and can take an undetermined amount of time. Certainly an unusual model.

Hi Vlad,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thank you for your patience.

Please try the attached fix and let us know if it works fine at your end. As per our development team, it was a difficult issue to investigate and the cause of the issue may be the use of formulas to determine the style. Please try / test it at your end too and let us know if it resolves your issue.

Thank You & Best Regards,

The issues you have found earlier (filed as PDFREP-31737) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.