We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Aspose PDF ComboBoxField Linux RedHat Enterprise 7.2 64bits

Hello, I’ve tried to use both Aspose.PDF 17.3 and 17.5 for Java, hoping that this issue would be solved, but seems like it keeps showing up.

The problem is that I can use ComboBoxField successfully on Windows, but running the same code (application) on Linux RedHat 7.2 64bit, both with Apache Tomcat 8.5.15, the select control won’t be added on the generated PDF document.
The constructor used is ComboBoxField combo = new ComboBoxField(pdfDocument, textRect). I’ve successfully added the ComboBoxField on Linux using the new ComboBoxField() constructor, but when I try to set the position (rectangle), the problem shows up again, so I believe there are some problems regarding the positioning rectangle.

Full stack:
com.aspose.pdf.internal.ms.System.z106: Specified method is not supported.
at com.aspose.pdf.internal.p62.z3.m2(Unknown Source)
at com.aspose.pdf.internal.p62.z3.(Unknown Source)
at com.aspose.pdf.internal.p75.z2.m1(Unknown Source)
at com.aspose.pdf.internal.p62.z29.m1(Unknown Source)
at com.aspose.pdf.internal.p63.z6.m1(Unknown Source)
at com.aspose.pdf.internal.p64.z1.m1(Unknown Source)
at com.aspose.pdf.ComboBoxField.m2(Unknown Source)
at com.aspose.pdf.WidgetAnnotation.m1(Unknown Source)
at com.aspose.pdf.Field.updateAppearances(Unknown Source)
at com.aspose.pdf.ComboBoxField.m1(Unknown Source)
at com.aspose.pdf.Field.m1(Unknown Source)
at com.aspose.pdf.Annotation.m1(Unknown Source)
at com.aspose.pdf.Annotation.(Unknown Source)
at com.aspose.pdf.WidgetAnnotation.(Unknown Source)
at com.aspose.pdf.Field.(Unknown Source)
at com.aspose.pdf.ChoiceField.(Unknown Source)
at com.aspose.pdf.ComboBoxField.(Unknown Source)
at pdfconverter.DocumentParser.addSelect(DocumentParser.java:740)

DocumentParser.java @line 740: ComboBoxField combo = new ComboBoxField(pdfDocument, textRect);

@mariusyk17,

Thanks for contacting support.

Can you please confirm if the problem is occurring with some specific document or it is occurring for all the files when using code snippet over Linux platform. From your above code snippet and description, it appears that you are adding ComboBoxField to PDF file but we need some details on either you are adding it to the document being generated from scratch or you are adding it to an existing PDF file.

Please share the details, so we may reply accordingly. We are sorry for this inconvenience.

Hello @codewarior,

I have a document already loaded, and based on some specific tags, I am trying to replace those tags with various input field types. Everything works as expected both on Windows and Linux, excepting this ComboBoxField. If you need further details, I can help you.

Thanks,
Marius Cirstea

@mariusyk17,

Thanks for sharing the details.

We are working on further testing the scenario based on above shared details and will keep you updated with our findings.

Hello @codewarior,

Any luck replicating the bug? We need this solved in our production servers as soon as possible.

Thanks,
Marius

@mariusyk17,

Thanks for your patience.

I have logged above mentioned problem as an investigation ticket as PDFJAVA-36872 in our issue tracking system. We will further look into the details of this problem and will keep you updated on the status of correction. Please be patient and spare us little time. We are sorry for this inconvenience.

Hello @codewarior,

Is there any way I can see the status of the ticket?
Thank you for your patience, too!

Marius

@mariusyk17

Thanks for your inquiry.

We have further investigated the issue at initial stage and according to our findings, the issue is encountering due to absence of basic fonts in the Linux environment. Though in your code, you were not using or setting any specific font during PDF generation but the API was using “Times New Roman” font as default, and that font must be present in the environment.

You can please try this scenario after installing the essential fonts in the Linux, which you are using and in case if you face any other issue, please feel free to let us know.


Best Regards,
Asad Ali

Thank you very much guys! This solved the problem, topic can be closed now.

Thanks again!
Marius Cirstea

@mariusyk17

Thanks for your feedback.

It is good to know that your issue has been resolved by suggested approach. Please keep using our API and in case of any further assistance, please feel free to let us know.


Best Regards,
Asad Ali