Free Support Forum - aspose.com

Aspose.PDF image quality issues

Hi

I am using Aspose.pdf to generate our PDF files. I have to show an image in the first page. The image looks 100% perfect in IE or other image viewing applications. When I use the same image in the PDF, the image lose it's quality.

Please help.

Thanks

Jay

Dear Jay,

Thank you for considering Aspose.

Which type of image are you using? Can you please attach the image and let us test it?

Hi

I am attaching the original image (LC.gif)

Thanks

Jay

Thanks for considering Aspose.

Plz reattach your LC.gif. We don't see any attachements now.

BTW, We have run a test of a simple gif and image quality is contained well in result pdf file.

Hi

For some reason, when I browse for the file and press preview button, I am not seeing the attachment. BTW, few months back I have been told in the post that aspose.pdf looses qulaity of image. The reason you are getting the file ok, because of the latest dll file. Could you please tell me that latest version of DLL.

I forgot to mention one thing that, the complaint from client is when they take the printout of a pdf page that has the image and saying that the image is garbled (I face the same issue).

Thanks

The attachment missing problem is a known issue and we will fix it soon. I can't find which version I have used to test your problem before. Please using the latest version of the dll.

Please reattach your file that can reproduce this error.

Please also note that if the image is scaled when added into the pdf and the DPI setting of the Adobe reader. That may affect the image quality.