Free Support Forum - aspose.com

Aspose.Pdf.Kit for .NET v2.4.0.0 is missing

Hello guys,


I’m using Pdf.Kit v2.4.0.0 in my application and now I have need yo print pdf document via PdfViewer but it crashes with next error:

Unable
to load DLL ‘Times-New.font’: The specified module could not be found.
(Exception from HRESULT: 0x8007007E) <o:p></o:p>

I found explanation on this error on next topic at your forum: http://www.aspose.com/community/forums/permalink/93123/93123/showthread.aspx#93123

Quote from thread: hi, if you will not use the Aspose.Pdf.Kit.PdfViewer or Aspose.Pdf.Kit.PdfConverter, you can only copy the dll and the xml; otherwise you should install Aspose.Pdf.Kit because some resourses need to be got according to some information in the register.

But I have only dll of Pdf.Kit and no recourse files at all.

And I wanted to download installer for Aspose.Pdf.Kit v2.4.0.0 but there’s no such installer on your site.

So if it’s possible to provide me with resource files or istaller for v2.4.0.0 of Pdf.Kit


Thank you in advance.

Hi Eugene,


Thanks for using our products.

The version of Aspose.Pdf.Kit for .NET which you are using is quite old and the post which you have referenced is also quite old. Please note that since June-2011, Aspose.Pdf.Kit for .NET has been discontinued as a separate product and its has been merged with Aspose.Pdf for .NET. All the classes and enumerations of legacy Aspose.Pdf.Kit for .NET are now present under Aspose.Pdf.Facades namespace of Aspose.Pdf for .NET.

In recent release versions, we have made many improvement in terms of PDF printing and other related features. I would recommend you to please try using the latest release version and in case you still encounter any issue or you have any further query, please share the source PDF file so that we can test the scenario at our end. We are sorry for your inconvenience.

Please visit the following links for information on

Hello,


Thank you for the quick response.
When I’m trying to use the newest PDF lib I have next exception:
The subscription included in this license allows free upgrades until 17 Jul 2009, but this version of the product was released on 28 Sep 2012. Please renew the subscription or use a previous version of the product.

Which is predictable. Does it mean I have to buy new licence? Because v2.4.0.0 is completely satisfies my needs and the only thing that I have set of libs but without any resource files. And I couldn’t find installer for this version not on yours site not in the internet. So if it is possible (if it still exists) to provide me installer for version 2.4.0.0. Or option to use the newest PDF lib is the only possible?

Thank you in advance.

Hi Eugene,


As I have shared earlier, the version of Aspose.Pdf.Kit which you have requested is quite old and we only keep versions newer than one year in download section (versions older than one year are removed). In current circumstances, I would again request you to please try using the latest release version.

For testing purpose, you may consider using the product in Trial mode or you may also request a 30 days Temporary license to test the new release version. Get a temporary license

In case the problem still persists, or you have any further query, please feel free to contact. We are really sorry for this inconveiniece.