Free Support Forum - aspose.com

Aspose.Pdf.Kit.PdfFileEditor.Append crashes every time

Hi all,

When I try to use the Append function I get an index out of range exception in the function
obfuscated.getPageSizeWithRotation(Int32)

When you leave AllowConcatenateExceptions set to false, you won't see an exception at all and the function will freeze indefinately until you stop debugging.

See the example code. Doesn't matter what PDF I use here, crashes every single time.

This functionality used to work in older version and most of our customers are still using version 3.8.0.1. For this German customer we had some problems translating umlauts and other German characters and version 3.8.0.1. translated these to block characters, so we switched to version 5.4.0.0. That fixed the problem with the umlauts They didn't use this functionality that used the Append function yet, but now they switched it on causing a crash.

Our licence for Aspose is until 05-27-2011, but the person being able to extend our licence isn't in the office for a while. Could you please help anyway?

Kind regards,

Hi Vincent,

I have looked into your code and noticed that you’re passing 0 as start page value. Please pass 1 instead. I have tried by changing this value and there was no exception. Also, if it still doesn’t work with the existing version then please try to use the latest version at your end.

I hope this helps. If you find any further questions, please do let us know.
Regards,

Hello,

Used to be 0 in older versions, and already tried newest version in demo mode, because of the licence, but changing the start page to 1 fixed the problem so thank you very much :)

Hi Vincent,

I’m glad to know that it helped. If you find any further questions, please do let us know.

Regards,