We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Aspose Presentation object not disposing even after call .Dispose()

Hi,

When I am trying to get text from presentation,After creating object of presentation I see the following issues:-

1. The Memory utilization goes higher and it never reduces even after disposing the object of presentation.


I tried to dispose the presentation object but even after that this does not release resources.


2) For testing purpose I commented the line of creating Presentation object and then Memory was not utilized so much.


I am attaching sample code and snap shot also.


Thanks in advance!!

Hi Gaurav,


Thank you for your interest in Aspose.Slides.

I have observed your comments and like to request you to please share with us the source presentation so that we may proceed further to help you out.

Best Regards,
Hi Muhammad,

I have attached sample presentation.Please have a look.

Thanks,
Gaurav Bhardwaj

Hi Gaurav,


I have observed your comments and have worked with the data shared by you. A ticket with ID SLIDESNET-37168 has been logged into our issue management system for further investigation and resolution of the issue. This thread has been linked with the issue so that you may be notified automatically as soon as this issue will be fixed.

We are sorry for your inconvenience,

Hello, we are still awaiting a reply on this issue. This delay could put our project timeline at risk. Can you please provide an update on the status of this issue, and provide an expected date for resolution?

Hi Gaurav,

I have verified the issue status from our issue tracking system and like to share that the issue has just recently been added in our issue tracking system and is pending for review at the moment. Our product team will schedule and investigate the issue on its due turn and after that we will be able to share further feedback with you in this regard. I will really appreciate your patience till the time our product team share its feedback.

Many Thanks,

Hi

I am experiencing the same issue.

I have tried using presentation.Dispose()

I have also tried "using" in every situation in which I load a presentation but still the memory never gets released... e.g.

using

(Aspose.Slides.Presentation presentation = new Presentation())

{

presentation.Save(documentNameAndPath, Aspose.Slides.Export.

SaveFormat.Pptm);

}

Hi Jason,


Thank you for posting.

I have observed your comments and like to share with you that the issue with Dispose method has been fixed for the upcoming version of Aspose.Slides for .NET. Tentative date of release for Aspose.Slides for .NET 16.2.0 is the first week of March 2016. We will share the notification with you as soon as the product will be shared online.

We are sorry for your inconvenience,

Many thanks.

I appreciate your help with this.

Jason

Hi Jason,


Thank you for sharing your feedback.

Please feel free to contact us if we can be of any help to you. We will share the notification as soon as the issue will be fixed.

Best Regards,

Hi Muhammad

Is the fix ready? If not do we have any idea when it will be ready?

Many thanks

Jason

Hi Jason,


I have observed your comments and like to share with you that the issue reported by you, SLIDESNET-37168, has been fixed for Aspose.Slides for .NET 16.2.0 which is likely to be released within a week. We will notify you as soon as the product will be shared online.

Best Regards,

The issues you have found earlier (filed as SLIDESNET-37168) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.