We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Aspose Replacing Tag Values Inside Of Docx Template

Hi.
I have an application that works for my local machine.
My application take my docx file as input and give me the tags that i have written on my docx file. I’m be able to change my tag values with these replacement values with use this application. I use Aspose words and pdf dlls version 18.1 and my license works.

Also i have a my server machine that i connected with remote desktop manager.
My application is not work on my rdm server machine. I don’t know what actual solution is.
I’m stuck at this step. As you shown on the attachment this is my docx template and output.
ENV.zip (12.4 KB)

@zelihaserbez

To ensure a timely and accurate response, please attach the following resources here for testing:

  • Please attach the output Word file that shows the undesired behavior.
  • Please attach the expected output Word file that shows the desired behavior.
  • Please create a simple console application ( source code without compilation errors ) that helps us to reproduce your problem on our end and attach it here for testing.

As soon as you get these pieces of information ready, we will start investigation into your issue and provide you more information. Thanks for your cooperation.

PS: To attach these resources, please zip and upload them.

Hi again.
I uploaded my application to drive.
https://drive.google.com/open?id=1QK1QUxnRSWSKhhehPNLWptODQ8CIKpKD

There is a docx file in Debug file which name is AAA.
My application is try to replace tag value with replacement value that you will see on my project.
Also i have a barcode font and use it with this project. It’s included to my drive folder.
I ran this application on my PC without error or etc. and tried another PC which has my barcode font but these two PC gave me different outputs without error. I have attached my two different outputs on below.
Thanks and have a nice forum.
0AAA_Desired_MyPC.pdf (33.4 KB)
AAA_Undesired_AnotherPC.pdf (32.6 KB)

@zelihaserbez

We have tested the scenario and have not found the shared issue. Please make sure that you have installed the font IDAutomationHC39M on the machine where you are not getting the desired output.