We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Aspose.Rpl Export

Good morning to everyone.


I’ve installed Aspose 5.2.2 for RS in sharepoint integrated mode.

The exports in PPT,PPS,PPTX and PPSX are working well.

I need to export a report in RPL, but if I follow the wiki at this page

http://www.aspose.com/docs/display/slidesreportingservices/Exporting+Reports+to+RPL+format

I can’t resolve my problem.

Can anyone help me?


thanks a lot

you can find attached my config files

Hi,


I have observed the issue shared by you and request you to please share the details of issue incurring on your end. I also like to add here that you need to use Aspose.ReportingServices.Debug.Rpl.dll in order to export to RPL and it is placed to C:\Program Files (x86)\Aspose\Aspose.Slides for Reporting Services\Bin\RplExport. So you must copy it to \Reporting Services\ReportServer\bin directory. Then add following string

into rsreportserver.config.

I hope this will be helpful. Please share, if I may help you further in this regard.

Many Thanks,

This is my problem (see capture2.png):


I don’t have any RPL EXPORT in the list

In Capture.png you can see where I put the DLL. I cant put the file in the \Reporting Services\ReportServer\bin directory,because I’ve installed SRSS in integrateg mode with share point, and I have another path (see CAPTURE.PNG)

I’ve attached my new config file.


Can you help me?

Thanks

Hi,

I would like to share with you that a ticket with ID SLIDESREP-33495 has been logged into our issue management system for further investigation and resolution of the issue. This thread has been linked with the issue so that you may be notified automatically as soon as the issue will be fixed.

We are sorry for your inconvenience,

Thanks a lot.


I’ll see for it. It’s really important for us.

Regards
Gaetano Parrello

Hi Gaetano Parrello,


I will update you as soon as feedback will be shared by our product team and will really appreciate your patience n this regard.

Many Thanks,

Hi Gaetano Parrello,


Our product team has investigated the issue shared by you and have shared following suggestions.

You must run next cmdlet in SharePoint Management Shell

$ssrs=Get-SPRSServiceApplication
New-SPRSExtension -Identity $ssrs -ExtensionType “Render” -name “ASRPLDEBUG” -TypeName "Aspose.Slides.ReportingServices.DebugRplRenderer,Aspose.ReportingServices.Debug.Rpl,Version=5.2.2.0,Culture=Neutral,PublicToken=b9adae394b5a0ec7"

and restart IIS. You can then check new installed renderer by

$ssrs=Get-SPRSServiceApplication
Get-SPRSExtension -Identity $ssrs

I hope this will be helpful. Please share, if I may help you further in this regard.


Many Thanks,

Hi,


thhanks for your advice, but when I run the second cmdlet I get this:

New-SPRSExtension : Extension name = ‘ASRPLDEBUG’, type = ‘Render’ already exis
ts.
At line:1 char:18
+ New-SPRSExtension <<<< -Identity $ssrs -ExtensionType “Render” -name “ASRPLD
EBUG” -TypeName “Aspose.Slides.ReportingServices.DebugRplRenderer,Aspose.Report
ingServices.Debug.Rpl,Version=5.2.2.0,Culture=Neutral,PublicToken=b9adae394b5a0
ec7”
+ CategoryInfo : InvalidData: (Microsoft.Repor…erviceExtension:
NewReportingServiceExtension) [New-SPRSExtension], InvalidOperationExcepti
on
+ FullyQualifiedErrorId : Microsoft.ReportingServices.SharePoint.PowerShel
l.NewReportingServiceExtension


Any other advice?

Regards
Gaetano

Hi Gaetano,

Can you please try executing following cmdlet on your end and share the feedback.

$ssrs=Get-SPRSServiceApplication
Get-SPRSExtension -Identity $ssrs -ExtensionType “Render”

Many Thanks,

Here the result:


PS C:\Users\gparrello> $ssrs=Get-SPRSServiceApplication
PS C:\Users\gparrello> Get-SPRSExtension -Identity $ssrs -ExtensionType "Render"


Name Type ExtensionType
---- ---- -------------
XML Microsoft.ReportingServices.R… Render
NULL Microsoft.ReportingServices.R… Render
CSV Microsoft.ReportingServices.R… Render
ATOM Microsoft.ReportingServices.R… Render
PDF Microsoft.ReportingServices.R… Render
RGDI Microsoft.ReportingServices.R… Render
EXCEL Microsoft.ReportingServices.R… Render
EXCELOPENXML Microsoft.ReportingServices.R… Render
RPL Microsoft.ReportingServices.R… Render
IMAGE Microsoft.ReportingServices.R… Render
WORD Microsoft.ReportingServices.R… Render
WORDOPENXML Microsoft.ReportingServices.R… Render
HTML4.0 Microsoft.ReportingServices.R… Render
MHTML Microsoft.ReportingServices.R… Render
ASPPT Aspose.Slides.ReportingServic… Render
ASPPS Aspose.Slides.ReportingServic… Render
ASPPTX Aspose.Slides.ReportingServic… Render
ASPPSX Aspose.Slides.ReportingServic… Render
ASXPSS Aspose.Slides.ReportingServic… Render
ASRPLDEBUG Aspose.Slides.ReportingServic… Render

Hi Gaetano,


Thank you for sharing the requested details. We are investigating the issue further on our end and will share the feedback with you as soon as it will be shared by our product team.

Many Thanks,

Good morning to everyone,


any news about this error?

Thanks a lot
Gaetano

Hi Gaetano,


I have verified from our issue tracking system and like to share that the issue is still under investigation by our product team. I will be able to share the further feedback with you as soon as it will be shared by our product team.

Many Thanks,

Hi Gaetano,

Please follow the steps below for configuring RPL render for SSRS in SharePoint mode:

1. Copy Aspose.ReportingServices.Debug.Rpl.dll from your C:\Program Files (x86)\Aspose\Aspose.Slides for Reporting Services\Bin\RplExport to
:\Program Files\Common Files\microsoft shared\Web Server Extensions\15\WebServices\Reporting\bin

2. Edit your rssrvpolicy.config (it is placed in :\Program Files\Common Files\microsoft shared\Web Server Extensions\15\WebServices\Reporting): add



see Asopose.Slides for Reporting Services manual installation article#rssrvpolicy for more detail

3. $ssrs=Get-SPRSServiceApplication

4. Remove-SPRSExtension -Identity $ssrs -ExtensionType “Render” -name "ASRPLDEBUG"

5. New-SPRSExtension -Identity $ssrs -ExtensionType “Render” -name “ASRPLDEBUG” -TypeName "Aspose.Slides.ReportingServices.DebugRplRenderer,Aspose.ReportingServices.Debug.Rpl”

6. Restart IIS

After configuring RPL please share the required report with us in RPL form along with issue details.

Many Thanks,
Mudassir:


After configuring RPL please share the required report with us in RPL form along with issue details.


I've done what you wrote from 1 to 6.
Then.. Where do I have to configure RPL from?

Regards Gaetano

Hi Gaetano,

I like to share that the steps that I have shared are infact for configuring RPL export in your environment. Once configured, you will be able to observe RPL export option in export options. Please shared if I may help you further in this regard.

Many Thanks,

Hi Mudassir,

I'm really pleased to tell you that IT WORKS!!! :)

Thanks a lot for everything

Regards
Gaetano

Hi Gaetano,

Its good to know things have worked on your end. Please share if I may help you any further in this regard.

Many Thanks,