We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Aspose.Slides memory issue

Hi Team,


I’m facing an issue with memory consumption when using Aspose.Slides library.

Attached you will find a sample console application which reflects the issue (removed all binaries for to reduce zip size. You will require to restore nuget packages to build). It also includes sample pptx file.

Memory reached 631mb and never got back to normal after running. On a server application this behavior is not acceptable as memory reaches the maximum at some point in time.
I’m using Aspose.Slides version 15.9.0.0 from Nuget Packages for .Net with .Net Framework 4.5.

If you need further information please just let me know.

Kind Regards,
Daniel

Hi Daniel,


Thanks for inquiring Aspose.Slides.

I have tested the application using Aspose.Slides for .NET 15.9.0 on my end. I have achieved 352 maximum memory utilization on my end in all instances and I think it is justified. Can you pleas share how we may call it a performance related issue. I have used Windows 7 x64 in CoreI7 2.6 Ghz with 8 Gb Ram.

Many Thanks,

Hi Mudassir,


Thanks for your answer.

Just to check, what happen if you change the code to make the for each to go to 300 instead of 200. Does it keep same memory utilization? Or does it keep increasing?

We use this tool inside a process in a server that convert files as they are uploaded by a tool. And, sooner or later server run outs of memory. If your make this test and memory keeps increasing after running more times the issue is still there.

Can you check that? I’m using Windows 10 x64 in Intel Core I7 2.4GHz with 32Gb Ram.

Thanks in advance for your cooperation.

Kind Regards,
Daniel

Ho Daniel,

I have observed the comments shared by you and an investigation ticket with ID SLIDESNET-37026 has been created in our issue tracking system to further investigate if it is really a performance issue with Aspose.Slides. This thread has been linked with the issue so that you may be automatically notified once the issue will be fixed.

We are sorry for your inconvenience,

Hi Mudassir,


Do we have news about this issue? We are still having the problem and it is getting really complicated. Can you inform me about the advance of the resolution on this matter?

Thanks in advance,
Daniel

Hi Daniel,


Thank you for getting back to us.

I have observed your comments and like to share with you that the issue reported by you, SLIDESNET-37026, has been investigated but it is pending for resolution at the moment. Our product team has been busy with priority issues and the ones reported earlier. Your issue was reported few weeks ago and it will be investigated on its due turn. We appreciate your patience in this regard.

Best Regards,

The issues you have found earlier (filed as SLIDESNET-37026) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.