Free Support Forum - aspose.com

Aspose.Slides.Net does not preserve the chart asix label


#1

Hi, I am trying to use Aspose.Slides.Net 17.12.1 to convert PPT into images. In the generated image, there are 2 issues:

  1. The axis title is changed from “Axis Title” to “CS Overall Performance 2014” in one of the chart.
  2. The vertical axis label direction is not vertical as the one in the original slide.

Here’s the ppt file.BadCharts.zip (32.3 KB)

Original slide: image.png (25.9 KB)

Generated Image: image.png (85.8 KB)


#2

@weihua,

I have observed your comments. Can you please share sample code so that we may further investigate to help you out. Also please share environment details with us.


#3

Thanks for your response. Our code follows your sample code here

Is this enough for you to investigate?


#4

@weihua,

I have worked with the presentation file using Aspose.Slides for .NET 17.12.1 and have been able to reproduce the issue. A ticket with ID SLIDESNET-39793 has been created in our issue tracking system to investigate and resolve the issue. This thread has been associated with the ticket so that we may share the notification with you once issue will be fixed.


#5

Hi @Adnan.Ahmad, what’s the status of this issue? Thanks!


#6

@weihua,

I have verified from our issue tracking system and regret to share that the issue is still unresolved. Actually, this issue is complex. We will share the good news with you as soon as it will be resolved.


#7

@Adnan.Ahmad, thanks for the update. Do you know if there is a workaround available before this is resolved.


#8

@weihua,

At present Iam unable to share and time frame and unfortunately there is no workaround approach availble. I request for your patience till the issue gets resolved.


#9

Hi @Adnan.Ahmad @mudassir.fayyaz, will you be able to share the time frame on this issue this time?


#10

@weihua,

I regret to share that the issue is still unresolved. We request for your patience till the time the issue gets resolved on our end.


#11

@Adnan.Ahmad, @mudassir.fayyaz, any update on this issue?


#12

@weihua,

I have verified from our issue tracking system and regret to share that the issue is still unresolved owing to internal API issues. We will share the good news with you as soon as the issues will be fixed.


#13

Hi @mudassir.fayyaz, any update on this? thanks!


#14

@weihua,

We regret to share that the requested feature is presently not supported in API and it is likely to be implemented during Q3 of 2019 owing to internally blocking missing API features.