We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Aspose.Total for .NET installer does not contain the .NET 4.0 binaries for Aspose.Words

I just noticed that the .NET 4.0 versions of Aspose.Words has not been updated on my development machine for over a year. It is still version 16.2.0.0, last updated on March 15, 2016. I have updated my Aspose binaries several times since that date, and both the 2.0 and 3.5 versions of Aspose.Words have the most recent timestamp; it’s just the 4.0 binaries that have not been updated.



When I looked at your downloads, it appears that the .NET 4.0 version of Aspose.Words is available from the installer for Aspose.Words, but it isn’t included in the installer for Aspose.Total for some reason.



I found this related post from about a year ago:



In that post, someone who was trying to do a trial with Aspose found that Aspose.Words for .NET 4.0 was missing from the setup package they installed. While the comments from Aspose indicate that you believed it was in the installer package, I don’t believe it was, based on the date of the post - this appears to be just after when the problem started.



Below is an image from the component table for the latest Aspose.Total for .NET msi. There is also the Aspose.Words.Remove component that appears earlier in the list (sorted alphabetically), but otherwise, there are no other components associated with Aspose.Words (which you can also see by inspecting the FeatureComponent table). There are no .NET 4.0 components listed, so assuming the names of the components are related to what they install, the .NET 4.0 version is missing.



The files for .NET 4.0 are included in the DLL-only version of Aspose.Total, but that’s just a zip file and not a full msi, the files in there are a little harder to work with (and are mixed by product, as well - it’s a mess in there), we prefer to use the msi.



Would it be possible to get the Aspose.Total for .NET msi fixed so that it contains the Aspose.Words binaries for .NET 4.0?



Thanks,

Michael Whalen

Hi Michael,


Thanks for your inquiry. While installing the Aspose.Words for .NET using Aspose.Total MSI, we have noticed that .NET 4.0 binaries are missing in Aspose.Words for .NET. We are coordinating with the concerned team for the fix and will update you accordingly.

We are sorry for the inconvenience.

Best Regards,