We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Aspose.Word for Android library exceeded heap space

Im working on an android project enhancement that should render/view a word document so Im looking to using Aspose.Word. I registered and was able to download a trial version and added the jar in the libs directory like the usual. I ran the project, no Aspose.Word usage or implementation yet, but the project won’t even compile anymore because of exceeded heap space. I already made adjustments to Eclipse memory and same result. Is there a special configuration for including this library?

Hi Katherine,


Thanks for your inquiry. No, there are no additional configurations required. What I understand, you’re not having this heap space error when you don’t place “Aspose.Words.1.8.0.jdk16.jar” in lib folder but as soon as you copy it, you start encountering this issue. I am afraid, I was unable to reproduce this issue on my end. I suggest you please try creating a new project by following the steps mentioned below:
http://www.aspose.com/docs/display/wordsandroid/Your+First+Application+Using+Aspose.Words+for+Android

I hope, this helps.

Best regards,