Free Support Forum -

Aspose.Word Java complied with JDK 1.7 and above

Hello team,

If I download Aspose Words Java, I see only JDK16 compiled version. JDK 1.6 is not supported as of Sept 2017. How could I get 1.7 or 1.8 or complied with Java 9?




There should not be any problem when using the latest version of Aspose.Words for Java I.e.18.7 with Java 9.

It just indicates that the codebase of Aspose.Words for Java had been migrated to JDK 1.6. We do not need different JARs for different JDK versions I.e. 1.6, 1.7, 1.8 and higher Java versions. The single JDK 1.6 jar is enough for all latest Java versions.

@awais.hafeez Java SE 6 has extended it’s support till Dec 2018. Do you have plans to move to higher Java version? Java 9 is already available. Are there any reason to stick to Java 6?
BTW, we use Aspose libraries with JRE 8. It would be great to have it complied with Java 8. Could you create a request item for it?


This is to ensure backward compatibility with JDK 1.6. I am afraid, we currently do not have plans to migrate code base of Aspose.Words for Java to Java 8.

Are you seeing some issues while using the 18.7 version of Aspose.Words for Java in your Java 8 or Java 9 environments?

As indicated in the thread, JDK 1.6 extended support is been made available until Dec 2018. JDK 1,7 end of support has been announced too. I am sure other customer would like to see that Aspose builds their bits with the supported JDK version.

Our main concern is around number of security issues associated with JDK 1.6. Hence, we would like to see Aspose use JDK 1.8. Is this in the near plan?


We have logged your requirement in our issue tracking system. The ID of this issue is WORDSJAVA-1851. We will further look into the details of this requirement and will keep you updated on the status of this issue. We apologize for any inconvenience.