We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Aspose.Word startup time takes minutes before getting to license loading

We are currently evaluating Aspose.Words (Java) and it seems like the startup time (before even looking for the license) is taking a considerable amount of time.


The steps we have performed:

1) Imported the Aspose.Words 14.5.0-jdk16.jar into a local Maven respository.
2) Included the dependency in our POM (compiled scope)
3) A static initializer to read and load the license file.

Before even getting to the static initializer Jetty will hang for almost 3 minutes before continuing on to loading the license file.

If we take the dependency out of Maven, Jetty starts up fine in a matter of seconds.

The environment we have now is:
- VirtualBox VM
- Jetty
- JDK7
- Google Guice and Guava
- Maven

As an additional note, if I run the license check in a JUnit it appears to run fine.

Is this startup time normal because it makes continual local develop-deploy-test cycles considerable inefficient to run?

I was able to solve this by adding the dependency to the maven jetty plugin as well. It still takes an additional few seconds but better than 3 minutes.

Hi there,

Thanks for your inquiry. It is nice to hear from you that you have solved your issue. Please feel free to ask if you have any question about Aspose.Words, we will be happy to help you.