We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Aspose-words-1.6 issues with Java 1.8

Hello,

We have a license aspose words as per subject and its currently used by our application in production systems running on Java 1.6 runtime. We are currently migrating our applications to new environment upgrading to Java 1.8 runtime and we noticed Aspose words no longer seems to work when merging data to fields.

Can you please advise if upgrade is needed for aspose words to get it running on Java 1.8 ?

Please advise,

Thanks,

–Mike

@mranile

Thanks for your inquiry. Could you please share the Aspose.Words version that you are using?

We are currently using version 1.6 of aspose.words.

@mranile

Thanks for sharing the detail. You are using very old version of Aspose.Words. We may try it with Java 8. However, we suggest you please use the latest version of Aspose.Words for Java 18.10.

Hello,

I got an error below after using the new version.

====================
Error loading license: java.lang.IllegalStateException: The subscription included in this license allows free upgrades until 08 Oct 2011, but this version of the product was released on 01 Oct 2018. Please renew the subscription or use a previous version of the product.

Is there a initial free license I can use to test the new version before we renew subscriptions ?

Please advise the soonest.

–Mike

@mranile

Thanks for sharing the detail. Please get the 30 days temporary license from here:
Get a Temporary License