We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Aspose.Words ASP COM Component stops responding

We have installed the Aspose.Words component and registered it for COM so we can use it in a classic ASP/VBScript page. The component works as expected for a few days and then for no apparent reason we get an 80070002 error on the create license. Restarting the server resolves the problem but there don’t seem to be any errors in the server logs. Is this anything that you’ve heard of before? We’ve only been using the component in production since June 29th and yesterday was the second time this has happened. Any assistance would be greatly appreciated.

Hi Nathaniel,

Thanks for your inquiry. Please make sure you have registered the assembly with /codebase flag as suggested in the documentation:


Please try re-registering the assembly with this flag and let me know if the problem still remains.

Best regards,

I checked with our sysadmin who did the actual registration and he told me that he used this command line (which includes the codebase switch):

cd “C:\Program Files\Aspose"
C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\RegAsm.exe /tlb:Aspose.Words.tlb Aspose.Words.dll /codebase
<!–[if gte mso 9]>
<w:WordDocument>
<w:View>Normal</w:View>
<w:Zoom>0</w:Zoom>
<w:TrackMoves/>
<w:TrackFormatting/>
<w:PunctuationKerning/>
<w:ValidateAgainstSchemas/>
<w:SaveIfXMLInvalid>false</w:SaveIfXMLInvalid>
<w:IgnoreMixedContent>false</w:IgnoreMixedContent>
<w:AlwaysShowPlaceholderText>false</w:AlwaysShowPlaceholderText>
<w:DoNotPromoteQF/>
<w:LidThemeOther>EN-US</w:LidThemeOther>
<w:LidThemeAsian>X-NONE</w:LidThemeAsian>
<w:LidThemeComplexScript>X-NONE</w:LidThemeComplexScript>
<w:Compatibility>
<w:BreakWrappedTables/>
<w:SnapToGridInCell/>
<w:WrapTextWithPunct/>
<w:UseAsianBreakRules/>
<w:DontGrowAutofit/>
<w:SplitPgBreakAndParaMark/>
<w:EnableOpenTypeKerning/>
<w:DontFlipMirrorIndents/>
<w:OverrideTableStyleHps/>
</w:Compatibility>
<m:mathPr>
<m:mathFont m:val=“Cambria Math”/>
<m:brkBin m:val=“before”/>
<m:brkBinSub m:val=”–"/>
<m:smallFrac m:val=“off”/>
<m:dispDef/>
<m:lMargin m:val=“0”/>
<m:rMargin m:val=“0”/>
<m:defJc m:val=“centerGroup”/>
<m:wrapIndent m:val=“1440”/>
<m:intLim m:val=“subSup”/>
<m:naryLim m:val=“undOvr”/>
</m:mathPr></w:WordDocument>
<![endif]–><!–[if gte mso 10]> /* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin:0in; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:10.0pt; font-family:"Times New Roman","serif";}

<![endif]–>I believe that we found that in your documentation after having some initial difficulty correctly registering the component. What we have found is that it is registered correctly (or appears to be) and works successfully for some period of time and then ceases so that we get an 80070002 error on the create license. I’ve also tried commenting out the create license, and I then get the same 80070002 error on the create comhelper.

We did find a thread on Microsoft Connect (http://connect.microsoft.com/VisualStudio/feedback/details/294241/kb937143-breaks-asp-to-net-com-interop) which seems to relate to a similar problem of COM components stopping. We are going to try the suggested registry fix and see if that helps. If not, I’m hoping that you may have some other suggestions or avenues for investigation.

Thanks you.

Hi Nathaniel,


Thanks for the additional information. You can also temporarily comment out Aspose.Words related code from your COM Wrapper to verify whether this may be specific to Aspose.Words or not. Please let us know if you have any troubles with Aspose.Words and we will be glad to look into this further for you.

Best regards,

Awais,

We’ve tried two things that we found in this StackOverflow thread that were related to the failure of generic COM components but neither one has resolved the issue.
http://stackoverflow.com/questions/8269076/server-createobject-failed-in-classic-asp
We tried the Microsoft KB937143
first,
http://connect.microsoft.com/VisualStudio/feedback/details/294241/kb937143-breaks-asp-to-net-com-interop, and then the suggestion by Renanlf.

We are not using a custom wrapper; just the methods exposed to COM through your dll. One of the reasons we picked Aspose.Words for this task was that we understood it could work in classic ASP for the limited use-cases we had without the need for any custom .NET wrapper.

Our website does use some other third party COM components and we have not had any similar problems so I’m wondering if there might be something that we did incorrectly in registering the dll or perhaps some obscure permission issues? Based on my reading of your forums it seems like we are not the only ones trying to use Aspose.Words in classic ASP.

Thanks for your help,
Nathaniel

Hi Nathaniel,


Thanks for the additional information. I will test the compatibility of Aspose.Words for .NET 13.6.0 with COM Interop and get back to you shortly. Sorry for the inconvenience.

Best regards,

Hi Nathaniel,


Thanks for being patient. Unfortunately, I could not reproduce this problem on my side. I used Aspose.Words 13.6.0 as well as the latest version 13.7.0 and the following code for testing; all works fine on my side:

<%
Dim lic
Set lic = CreateObject(“Aspose.Words.License”)
lic.SetLicense(“C:\Temp\Aspose.Words.lic”)
’ Open document
Dim doc
Set doc = CreateObject(“Aspose.Words.Document”)
’ Create DocumentBuilder.
Dim builder
Set builder = CreateObject(“Aspose.Words.DocumentBuilder”)
builder.Document = doc
builder.Write(“Hello world!!!”)
’ Save output document
doc.Save(“C:\Temp\out.pdf”)
%>

I would suggest you please try re-installing the latest version of Aspose.Words (13.7.0) by using MSI installer. After the installation is completed, please re-register Aspose.Words for COM Interop using the regasm.exe utility.

Best regards,