We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Aspose.Words assembly could not be loaded on end user system

Hello,

I developed a Word addin for Word 2003 and want to use the aspose components to automate word to pdf conversion and save it in a database, all from an application running inside word. On my develop machine it works fine, however when I deploy a setup and install it on the end user system, I get the following error:

Could not load file or assembly ‘Aspose.Words, Version=4.4.3.0, Culture=neutral, PublicKeyToken=716fcc553a201e56’ or one of its dependencies. Failed to grant permission to execute. (Exception from HRESULT: 0x80131418)

I read some topics on the forum about writing a COM wrapper. Is that also here necessary? The only thing I use is Open the document, and save it to Xml.

Any ideas?

Regards,

Dennie Pasman

Hi

Thanks for your inquiry. Maybe you should register Aspose.Words.dll in GAC.

gacutil /i C:\Program Files\Aspose\Aspose.Words\Bin\net2.0\Aspose.Words.dll

Best regards.

Thank you for your help. I tried that too, but it still doesn’t work on an end user system.

I think I need to grant FullTrust to the assembly. I’m currently using the SetSecurity project for my VSTO application. I probalby need to configure it for Aspose.Words too.

Regards,

Dennie

I solved my problem. Had to use indeed SetSecurity to grant rights to Aspose.Words.dll and Aspose.Pdf.dll.

Regards,

Dennie