Free Support Forum - aspose.com

Aspose.Words for .Net - Formatting Issues

Hello there,

I am using Aspose Words for .Net version-9.5 in my Reporting service project.
Though I was facing some formatting issue during initial phase of testing as mentioned in following thread:

http://www.aspose.com/community/forums/thread/220233/image-formatting-issue-while-genrating-html.aspx

but as v10 has many formatting issues resolved, I thought to give it a try before actual upgrading my current version of Aspose… so that our clients needn’t change their existing templates.

As I tested with v10, I found that there are still some formatting issues as you can see from attached documents:
Details FLAT 1 - Origional.dot (Origional document from the client)
v10Details FLAT 1 - After Conversion.docx (I convert the place holders to meet with correct template standard in my application, done before saving user’s uploaded document)

Output Documents after Mail Merge -
v10Details FLAT 1 - Output.Docx
v10Details FLAT 1 - Output.Pdf

Could you please guide if we can do anything to retain same formatting as in origional document.

Thanks and Regards
Nutan

Hi Nutan,

Thanks for your request. The problem with rendering to PDF occurs because in your document you are using Tight text wrapping of shapes. Aspose.Words does not support this type of wrapping upon rendering. That is why some shapes are misplaced. However, it is not clear for me why the same problem occur in DOC on your side. On my side DOC file looks the same as the template. Maybe the problem is caused by your code. Could you please create a simple application that will show how you process the original template?

Best regards,

Hello Alexey,

I tried with simply saving the input .dot file to .docx without any processing in between, still there are some formatting issues:

1. One page in source document, splitted to two pages in output document
2. Text in the blue box at bottom of page is missing with some of it being moved to box with code PhotoC.

I have attached Input and Output doc for your reference.

Please guide.

Hello

Thank you for reporting this problem to us. I managed to reproduce the problem on my side. Your request has been linked to the appropriate issue. You will be notified as soon as it is resolved.

Best regards,

Hello Andrey,

Is it possible to give an approximate time frame I can expect it to get resolved.

Thank you!

Hello

Thanks for your request. At the moment this issue is pending for analysis. The responsible developer will analyze the issue and we will be able to provide you an estimate.

Best regards,

Thanks for the quick update.

I will wait to hear back from you regarding estimate.

Also, as we were thinking to upgrade our Aspose version to current release, It will be good if estimate comes out to be approx. 1-2 months.
However, if it is more than 1-2 months, please see if you could provide me with a work around to get the correct output.

Thank you!

Hello

Thanks for your request. As soon as the responsible developer will analyze the issue I will be able to provide you an estimate.

Best regards,

Any update on this?

Hello

Thanks for your request. Unfortunately, there is no estimate specified for this issue yet. Once our developers review the issue and provide an estimate, I will let you know.

Best regards,

The issues you have found earlier (filed as WORDSNET-4861) have been fixed in this .NET update and this Java update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.