We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Automatically Hyphenation into MailMerge-Document

Hi Aspose Words team!
I would like turn on automatically hyphenation into a paragraph, which contains 0…n mergefields. I use following two snippets, but not one was successful.

Dim builder As DocumentBuilder = New DocumentBuilder(e.Document)
1. builder.CurrentParagraph.ParagraphFormat.SuppressAutoHyphens = False
2. builder.ParagraphFormat.SuppressAutoHyphens = False

How can I activate the hyphenation automatically. I use the Words version 8.0.0.0 for .NET.

Best regards
Birgit

Hi

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thanks for your inquiry. Unfortunately, there is no way to enable/disable this option for whole document. Currently you can only disable hyphenation for a particular paragraph:

http://www.aspose.com/documentation/.net-components/aspose.words-for-.net/aspose.words.paragraphformat.suppressautohyphens.html

If you are building document from scratch, you can create an empty document in MS Word, enable auto-hyphenation in this document and use it as template for your documents.

Best regards,

Hello aspose team,
thanks for these information. But whatever the value of SuppressAutoHyphens is it, the hyphenation not works into aspose words version 8.0.0.0.
Do you know the hyphenation suppressing works with the current aspose words version?

Best regards
Birgit

Hello

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thanks for your inquiry. As I mentioned earlier, currently, there is no way to enable “Auto Hyphenate” option on a document using the latest version of Aspose.Words. You will be notified as soon as it is supported.

SuppressAutoHyphens option just specifies whether the current paragraph should be exempted from any hyphenation which is applied in the document settings.

Best regards,

Hi Birgit,

Thanks for your request. Actually, I suppose SuppressAutoHyphens option works in both in 8.0.0 and in the latest version. However, you will be unable to see its effect if hyphenation is not enabled for whole document. Unfortunately, as Andrey mentioned there is no way to enable this option for whole document using Aspose.Words.

As a temporary solution, you can use template document where auto-hyphenation is enabled. Just use this template to generate your documents using Aspose.Words, in this case auto-hyphenation option will be preserved and you will get the desired result.

Best regards,

The issues you have found earlier (filed as WORDSNET-2338) have been fixed in this .NET update and this Java update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.
(13)