We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

AW for SSRS does not work

I install Aspose Words for Reporting Services. ReportManager hangs when rendering any report to any format supported Aspose Words. Unfortuantly I have no error and I cannot say anything about the problem. <?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

First I tried to install Aspose Words for Reporting Services using msi but failed. Error occurred: “Could not install or configure Aspose.Words for Reporting Services on this machine. Please try installing Aspose.Words for Reporting Services manually as described in the documentation “. I installed it manually.

My configuration is the following: SQL Server 2008 R2 on one server (Windows Server 2008 R2 Enterprise SP1 64-bit) and SQL Server 2008 Reporting Services on another server (Windows Server 2008 R2 Enterprise SP1 64-bit).

To tell the truth I installed Aspose.Words for Reporting Services on my computer (Windows 7 32-bit) with SQL Server 2008 32-bit and everything is Ok.

Does your product support SQL Server 2008 R2 64-bit?

Hi Sergey,


Thanks for your request. Have you tried installing Aspose.Wors for Reporting Services manually, as described here?
http://docs.aspose.com/display/wordsreportingservices/installing+on+the+server+manually

Maybe this could help you to resolve the issue.

Secondly, yes, you can generate reports with Aspose.Words for Reporting Services on the machine i.e. having Microsoft SQL Server 2008 Reporting Services (32-bit or 64-bit, Standard, Developer or Enterprise edition) installed.

Best Regards,

I installed Aspose Words for Reporting Services manually on my computer and server using http://docs.aspose.com/display/wordsreportingservices/installing+on+the+server+manually and I can make a conclusion that you product does not support SQL Server 2008 R2. Am I right in thinking so? I'd like to draw your attention to the fact that SQL Server version is R2.<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Hi
Sergey,


Thanks for the additional information. Aspose.Words for SSRS does support SQL Server 2008 R2 (I tested it in express edition but it should work on enterprise edition as well). Please see the following link to learn more about system requirements of Aspose.Words for Reporting Services:
http://docs.aspose.com/display/wordsreportingservices/system+requirements

Please let me know if I can be of any further assistance.

Best Regards,

I see but nevertheless in my case Aspose.Words for SSRS does not work. Let’s try to solve the problem. First of all I’d like to say that I found a similar post: http://www.aspose.com/community/forums/253554/aspose-evaluation/showthread.aspx#253554. Besides when I render a report to any format supported Aspose Words I can see in ReportServerService.log the following:


library!ReportServer_0-18!19fc!02/24/2012-14:22:49:: Call to GetSystemPropertiesAction().

library!ReportServer_0-18!1b40!02/24/2012-14:22:50:: Call to GetPermissionsAction(/ReportFolder/Report1).

library!ReportServer_0-18!1510!02/24/2012-14:22:50:: Call to GetSystemPropertiesAction().

library!ReportServer_0-18!4304!02/24/2012-14:22:50:: Call to GetPropertiesAction(/ReportFolder/Report1, PathBased).

library!ReportServer_0-18!27f8!02/24/2012-14:22:50:: Call to GetSystemPermissionsAction().

library!ReportServer_0-18!4304!02/24/2012-14:22:50:: Call to GetSystemPropertiesAction().

library!ReportServer_0-18!2444!02/24/2012-14:22:50:: i INFO: RenderForNewSession('/ReportFolder/Report1')

webserver!ReportServer_0-18!2444!02/24/2012-14:22:50:: i INFO: Processed report. Report='/ReportFolder/Report1', Stream=''

library!ReportServer_0-18!36c8!02/24/2012-14:24:25:: i INFO: RenderFromSession('/ReportFolder/Report1')

Could you tell me what information I should give to you to improve the situation?

Hi Sergey,


Thanks for the additional information. Could you please attach your rdl report and rdl.data file here for testing? We will investigate the issue further on our side and provide you more information.

Best Regards,

I have a similar issue with Aspose.Word. I do not see any of the AW rendering options in the drop down.

Sending an RDL and RDL data would not help at all. We like this product when it is successfully installed but have never been able to install in automatically in the past on any of our servers over the years which is quite suprising given that the install is rather simple. Copy a dll to an instance folder and update two config files.

I attempted to manually install the latest version of Aspose.Word dated 02-15-12. It appears that the install instructions, including the xml code to paste, is the same as it was over a year ago. Should it be updated for the current version. Specifically, shouldn't the "Public Key Blob" be different?

Hi Dayle,


Thanks for your inquiry.

Actually, you do not need to copy or modify any files manually unless you want to add special configuration parameters.

Moreover, using the MSI installer is the best option because it works in most cases. However, you may want to install the product manually in the following situations:

  1. Automatic installation fails due to some error such as a security issue.
  2. You want to install the product on specific instances of Reporting Services only.
  3. You have Microsoft SQL Server Reporting Services installed on your computer but only want to use Aspose.Words for Reporting Services with Report Viewer.

I would suggest you please try installing Aspose.Words for Reporting Services v3.5.0 via MSI installer from the following link and let us know how it goes on your side:
http://www.aspose.com/community/files/52/ssrs-rendering-extensions/aspose.words-for-reporting-services/default.aspx

Best Regards,

Awais,

Thanks for the quick reply. I did not know you had replied because my "post" notificaiton was turned off.

I must install on specific instances. We have hundreds of reports in other instance sand cannot go thru a rigorous testing exercise on all of them at this time. The manual instructions on your site appears to be specific to a developer workstation installation are there other instructions? Also, I am fairly sure that in the past you could choose from various instances on a server. It would be ideal if I could do that now.

Thanks

Hi Dayle,

Thanks for sharing the information. There should not be issue if you have multiple sql server instances at same machine. Please make sure that you are installing Aspose.Words for SSRS for proper instance. It would be great, If you share your working environment like operating system, SQL server etc.

What problem you are facing while installing Aspose.Words for SSRS with MSI installer?

http://docs.aspose.com/display/wordsreportingservices/Installing+on+the+Server+Manually


I don't understand. You say it isn't a problem to install if I have multiple sql instances on the same machine. As I stated previously, it is a problem. I do not want Aspose.Word upgraded across all instances. Only specific ones. I do not have the resources to test hundreds of reports in other instances with the new version.

The MSI doesn't give me the option to pick specific and incidence at least when I install it on my laptop which only has one instance. I tried the MSI on a multi-instance machine and it did not give the option to choose either so I canceled the install. This is why I am doing the manual install.

The main issue here is that after doing the manual install, I do not get the Aspopse export options in the drop list in the Report Manager page that shows report output. The version of the instance is SSRS 2008 R2.

Hi Dayle,

Thanks for sharing the information. Please first uninstall the Aspose.Words for SSRS completely from your system. After this, please install manually Aspose.Words for SSRS for specific instance.

If you still face problem, please let me know.

That is quite a lot of work given there given there are a total of 10 instance in dev and prod and they are all manually installed because the manual install has always failed. I suppose they would then all need to be manually uninstalled then manually reinstalled again.

Please detail what overlap there is between instances that will technicall justify pursuing this course of action. Based on the 3 step install process, I don't see any commonality between the instances that would lead to resolving the issue.

Hi Dayle,

Please accept my apology for late response. It would be great, If you setup Aspose.Words for SSRS manually at separate system and let us know, If you still face problem.

It would be great if you could answer my previous post:

Please detail what overlap there is between instances that will technicall justify pursuing this course of action. Based on the 3 step install process, I don't see any commonality between the instances that would lead to resolving the issue.

Again, this would be a lot of work and given the failure of the auto install in the past, I do not believe it will work in the future.

Can you at least explain why the export options are not displayed?

Hi Dayle,

Please accept my apology for late response. It seems that you have not properly installed Aspose.Words for SSRS manually. I am working on your issue and will update you soon.

I may have made a mistake but I've done this correctly, many times in the past. A few postings ago I asked this question:

I attempted to manually install the latest version of Aspose.Word dated 02-15-12. It appears that the install instructions, including the xml code to paste, is the same as it was over a year ago. Should it be updated for the current version. Specifically, shouldn't the "Public Key Blob" be different?

Is it correct that the public key should be the same?

Hi Dayle,

Please accept my apology for late response. I have setup virtual machine for your issue. I will do the followings to reproduce your issue at my. Please correct me, If I am wrong.

  1. Create multiple instances of SQL server
  2. Install Aspose.Words for SSRS by using MSI installer
  3. This will show the conversion options of Aspose.Words for all sql server instances
  4. Uninstall Aspose.Words for SSRS for one instance of sql server
  5. Aspose.Words for SSRS conversion options should be visible for other sql server instances

I noticed and error on server's event view it states:

  • Report Server (OAM2008R2) cannot load the AWDOC extension

What would cause this?

Please answer my previous question about the public key blob? Does it not change will new releases?

If you need to do what you describe in the previous post, please install a 2008 instance and then a 2008R2 instance.

Hi Dayle,

It is nice to hear form you that you have noticed the error. I have asked about PublicKeyBlob from our development team. As soon as, any information is shared by them, I will be more then happy to share that with you.