We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Background for graphic elements was changed during conversion from ppt to pdf

We use Aspose.Slides 16.7.0 to convert input.ppt into pdf. And during conversion background for graphical elements was changed.
We use following code:
using (var presentation = new Presentation(“input.ppt”))
{
presentation.Save(“output.pdf”, SaveFormat.Pdf);
}

You can observer difference by navigating on 5th page (or by opening illustration.png)

Hi Matt,


I have worked with the presentation shared by you using Aspose.Slides for .NET 16.7.0 and have been able to observe the issue. A ticket with ID SLIDESNET-37878 has been added in our issue tracking system to resolve the issue. This thread has been associated with the ticket so that we share notification with you once issue will be fixed.

We are sorry for your inconvenience,

Thank you, Ahmad!
I will be very appreciated if you update this topic with ETA\fixed version when this information become available.

Hi Matt,


Sure, Any new update from our product team will be shared with you.

Best Regards,

The issues you have found earlier (filed as SLIDESNET-37878) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.

Hello,

Issue is reproducible on Win 10-64bit with Aspose.Slides 16.10.0 (XDAS-157)

Important thing here is that background is changing on objects that are vector images.


Steps to create a PowerPoint file with such problem object:

  1. Create a shape in PowerPoint and apply pattern fill to it.
  2. In context menu select Save as picture and select EMF format.
  3. Insert resulting picture in presentation.
  4. Save presentation and import it to DA app (see attached).

ER Shape background is displayed as in PowerPoint
AR Shape background is changed



Please confirm and provide fix ETA

Hi Matt,


I have observed your comments. We are looking into this and will get back to you with feedback soon.

Best Regards,

Hi,

Would you please update me on the estimates?

Hi Matt,


Please use Aspose.Slides latest version 16.11.0 on your end. Please share feedback with us if there is still an issue.

Best Regards,

Hello,


Issue is still exist with Aspose.Slides 16.11.0.
Please use test_pattern_fill.pptx attached to reproduce.

Hi Matt,


I have worked with the presentation shared by you using Aspose.Slides for .NET 16.11.0 and have been able to observe the issue. A ticket with ID SLIDESNET-38203 has been added in our issue tracking system to resolve the issue. This thread has been associated with the ticket so that we share notification with you once issue will be fixed.

We are sorry for your inconvenience,

The issues you have found earlier (filed as SLIDESNET-38203) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.

Tested with Aspose.Slides 17.2. Issue is no longer reproducible with file test_pattern_fill.pptx. But reproducible with another file sample.pptx (attached).

Hi Matt,


I have worked with the presentation shared by you using Aspose.Slides for .NET 17.2.0 and have been able to observe the issue. A ticket with ID SLIDESNET-38424 has been added in our issue tracking system to resolve the issue. This thread has been associated with the ticket so that we share notification with you once issue will be fixed.

We are sorry for your inconvenience,

The issues you have found earlier (filed as SLIDESNET-38424) have been fixed in this update.